Easy Install error for production

Cant find a sulotion here in the forum… Please help me im a little bit confuse about the installation instruction… I already follow the Easy install instruction… im using ubuntu 14.04 server.

Traceback (most recent call last):
File “install.py”, line 388, in
File “install.py”, line 114, in install_bench
run_playbook(‘production/install.yml’, sudo=True, extra_vars=extra_vars)
File “install.py”, line 326, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/subprocess.py”, line 540, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘production/install.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2

try to add frappe user before
$ adduser frappe
$ su - frappe
then run easy install script

i tried to follow your instruction before i run easy install but i cant run any of the easy install installation instructions. like
apt-get install python-minimal
but it will send an error asking are you root?
sudo apt-get install python-minimal
and send an errror “frappe is not the sudoers file this will be reported”

Is there anyway to make this simple as possible for installing erpnext for making a server own my own?

i reinstall a new ubuntu server before i run easy install script i add frappe user… it woks!

1 Like