Easy Install on Digital Ocean Ubuntu 18.04

Hi all,

I get the following error when I use Easy Install on a new server on Digital Ocean Ubuntu 18.04:

Traceback (most recent call last):
File “install.py”, line 500, in
File “install.py”, line 281, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “install.py”, line 416, in run_playbook
success = subprocess.check_call(args, cwd=playbooks_folder, stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python3.6/subprocess.py”, line 311, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=mmpy3’]’ returned non-zero exit status 2.

I tried some of the other problems that have been reported by other users, but didn’t find a solution or manage to solve the problem.

Any pointers?



Hi Jayram

As far as the easy install script goes, I don’t think it is regularly being updated.
Back in May I had tried couple of times, but it kept giving bugs.
So I have since resorted to manual install.