Easy Install on Ubuntu 18.04 fails to make a working ERPNext

I have a clean Ubuntu 18.04 server which has had the Easy Install used on it. (GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps)
I opted for the Production version and have setup https.

As Ubuntu user:

 1  sudo sh -c 'apt-get -y update && apt-get -y upgrade && apt-get -y dist-upgrade'
 2  sudo reboot
 3  wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py
 4  apt-get install python-minimal
 5  sudo apt-get install python-minimal
 6  sudo apt-get install build-essential python-setuptools
 7  sudo python install.py --production --user frappe
 8  sudo su frappe

As Frappe user

 1  cd
 2  ls
 3  cd frappe-bench/
 4  ls
 5  cd sites
 6  ls
 7  cd ..
 8  ls
 9  cd apps
10  cd frappe
11  git status
12  cd ../erpnext/
13  git status
14  cd ~/frappe-bench/
15  ps axf | grep redis
16  ls
17  cd ..
18  ls
19  cd /var/log/
20  ls
21  cd ~/frappe-bench/
22  bench dns_multitenant_on
23  bench dns_multitenant on
24  bench dns_multi_tenant on
25  bench
26  bench config dns_multitenant on
27  bench setup nginx
28  sudo service nginx reload
29  sudo -H bench setup lets-encrypt site1.local
30  sudo -H bench setup lets-encrypt <my-domain-name>
31  bench drop-site site1.local
32  bench add-site <my-domain-name>
33  bench new-site <my-domain-name>
34  sudo -H bench setup lets-encrypt <my-domain-name>
35  bench update

This is the entire command history so you can see exactly what I’ve done and what I’ve not done.
When I log into ERPNext (over https, on port 80) I get this:

There’s a distinct lack of menu entries - Manufacturing, Sales, HR…

I’ve checked (commands 9 to 13) that both erpnext and frappe are on upstream/master branch. There are no errors that I could see during the install process other than python2.7 deprecation and other inconsequential errors.

Any clues as to what’s going on?

In the Setup module in the Permissions section, check Show / Hide Modules that these above are visible.

This may help with clues too Reset Administrator - #20 by fkardame

To be honest, it looks like only frappe was installed and the erpnext app didn’t get installed.

Otherwise you would see the Projects, CRM, Buying, etc. links. I ran into this once when I was adding a second tenant to the multi-tenant installation. The second tenant had no links except the ones this user had shown in the pics above. However, the main site (site1.local) was fully populated.

To solve this I ran the following command from the frappe-bench directory

bench --site [sitename] install-app erpnext (replace [sitename] with your site name)

It will then install the database and ask you for the Administrator password to assign to the MariaDB database for the new site.

I may be wrong, but this sure does look familiar. So, it is worth a try on your end.
Remember… Your Mileage May Vary

Hope this helps… :sunglasses:


1 Like

The app installer missing from V11.

Thank you.

Yes, I deleted the default site to get a “proper” URL for the https setup, but then didn’t install the erpnext app in the new site.

Hmm… I have never had to delete site1.local to make anything work. All I do is delete everything in the site_config.json except the database name and password strings, then run:

bench setup nginx
sudo service nginx restart

With this I can change the URL that was previously given to the site1.local, I just reboot after this and run:

bench setup add-domain --site site1.local [sitename]
bench setup nginx
sudo service nginx restart

And then I have whatever I decided in my new URL in the setup add-domain command.

I do this all the time because I have a working server image file that I restore to a new server and then change the URL without having to add a second tenant site.

Anyway… glad to hear you got something working.


1 Like