Easy Installation - But Page not opening?

I’m sorry. The correct command is:
bench get-app erpnext https://github.com/frappe/erpnext

1 Like

Yes, it worked… Thanks a lot.

What next how can i start using it now, I mean i can do bench start and can login to administrator
but what about ERP where it is?

As @Sagar_Vora has mentioned above you need to install it.

Go to ~/frappe-bench and bench get-app erpnext

bench get-app [app-name] [repo-link]

Yes, I tried that but getting same error as -:
~/frappe-bench$ bench get-app erpnext
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/ubuntu/.bench/bench/cli.py”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/ubuntu/.bench/bench/commands/make.py”, line 30, in get_app
get_app(git_url, branch=branch)
File “/home/ubuntu/.bench/bench/app.py”, line 53, in get_app
repo_name = git_url.rsplit(‘/’, 1)[1].rsplit(‘.’, 1)[0]
IndexError: list index out of range

Now, you have the app, but it is not yet installed. So, install it.
bench --site site1.local install-app erpnext

But ERPNext cannot be used on a site which is already setup.
So, after the above command, run this:

bench --site site1.local --force reinstall

Please note that above command will wipe the database for site1.local.

Thanks, I followed above steps everything goes without error.
can login to administrator and can get same screen as earlier.

Is there anything more i need to do to get ERPnext screen.

Sorry, I forget to account for the fact that after reinstall, the site does not have any apps except frappe.
bench --site site1.local --force reinstall
and then:
bench --site site1.local install-app erpnext

Check if setup wizard asks you for customer, supplier, item details. If yes, erpnext is installed.

I tried this command, but end up with following error , although installation finished successfully with error, I’m still not able to open the site , I still get 401 error in bench log.

Error: File to import not found or unreadable: frappe/public/scss/website/variables