Easy Installation - But Page not opening?

Hi All,

I just did Easy Installation of ERPNext everything goes well as expected.

installation done on AWS - Ubuntu 16.04 Server, after installation i found frappe-bench directory in ubuntu home directory.i followed instruction as bench start - result all started well but while i browse web page says -:
Error: ENOENT: no such file or directory, stat ‘/home/ubuntu/frappe-bench/index.html’
at Error (native)
I am trying to browse with IP:9000

Kindly help !!!


To my knowledge, ERPNext does not use port 9000.

If you have installed develop mode the port will be 8000 or 8080

If you have installed production mode you should just enter the IP or domain where you installed it



Thanks for your response,
I have installed Development one, and on port 8000 i am getting blank screen.

I am not clear why this error of no such file or directory, stat '/home/ubuntu/frappe-bench/index.html

The development version needs to be started using bench.
In your terminal do the following
cd ~/frappe-bench bench start

Yes, I did that and it started too…
find attached is the output m getting after starting.

Where are you running ERPnext from?

  1. A Virtualbox Virtual Machine ? or you need to enter the IP:8000
  2. Your Local Desktop/Laptop? or you can use
  3. Server? You need to IP of the server IP:8000

I have done this installation on Amazon Cloud Server - OS - Ubuntu 16.04
Yes, I have the IP for server, is there any file or something in ERPnext where i can specify server IP.

All the required ports are open like 8000 / 9000 / 8080

There is no need to assign/specify the server IP in ERPNext. Basically, once nginx is running which it is, the default external IP assigned to the server will be enough.

If I am not mistaken, you actually need to assign an external IP for Amazon servers (EC2) – Elastic IP

One more thing i found when ever i try to browse attache line show like dose not exist.
check the screenshot.

Try and use the address you ssh to the server with the addition of port 8000

If you are able to load ERPNext, that means an external IP (Elastic IP) has not been attached to the Instances where you created ERPNext

Yes, I was trying with that ip only which i use for SSH and its not working, So now I have assigne Elastic IP
but i still the problem is same. :disappointed_relieved:


Check your current site is valid or not, you can check the current site at /frappe-bench/sites/current_site.txt

if current_site.txt is empty run the bench use your_site_name command then run bench start


1 Like

Hi Makarand,

I checked that location but there are only 3 files available -:

  1. apps.txt
  2. assets/ (Directroy)
  3. common_site_config.json

Not sure what happened during the install, but there definitely needs to be more files & folders than that

Sometimes, its easier to just start from scratch and the following steps have been tried and tested on Ubuntu 16.10

sudo apt-get update
sudo apt-get upgrade
sudo adduser frappe
sudo usermod -aG sudo frappe
sudo nano /etc/resolv.conf (change DNS to and
sudo apt-get install python-minimal && python -V # was 2.7.12+
wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py
sudo python install.py --production

or alternately if you wish to try with the same install try the following:

~/frappe-bench$ bench reinstall
~/frappe-bench$ bench update
~/frappe-bench$ bench start

Hope this helps.

I am trying to reinstall but it gives -:
ubuntu@ip-172-31-28-130:~/frappe-bench$ bench reinstall
This will wipe your database. Are you sure you want to reinstall? [y/N]: y
Please specify --site sitename

This is a new install right, so it should not matter if it wipes the database and the default site is usually named site1.local unless you have domain or subdomain for the install you can use that as well for the site name

bench reinstall --site yoursitename.com

Now the output is -:
ubuntu@ip-172-31-28-130:~/frappe-bench$ bench reinstall --site site1.local
Error: no such option: --site

Hi All,
I followed this steps which comes in Manual Installation -:
ubuntu@ip-172-31-28-130:~/frappe-bench$ bench new-site site1.local
MySQL root password:
Installing frappe…
Updating DocTypes for frappe : [========================================]
Updating country info : [========================================]
Set Administrator password:
Re-enter Administrator password:
*** Scheduler is disabled ***

And now I can access login page, also could login to admin as well
but dont understand how to get in to ERPNext ?

I also tried Install erpnext-:
To install erpnext on your new site, use the bench install-app command
bench --site site1.local install-app erpnext but it says -:
Could not find app “erpnext”

bench get-app erpnext

Hi Sagar,
It says -: IndexError: list index out of range

Output -:
ubuntu@ip-172-31-28-130:~/frappe-bench$ bench get-app erpnext
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/ubuntu/.bench/bench/cli.py”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/ubuntu/.bench/bench/commands/make.py”, line 30, in get_app
get_app(git_url, branch=branch)
File “/home/ubuntu/.bench/bench/app.py”, line 53, in get_app
repo_name = git_url.rsplit(‘/’, 1)[1].rsplit(‘.’, 1)[0]
IndexError: list index out of range