EASy installation error

Hi everyone i currently making a new server for production and im following the easy install with 16.04 ubuntu…it throws an error when i ran
python install.py --develop --user frappe
this is the error

Traceback (most recent call last):
File “install.py”, line 417, in
File “install.py”, line 122, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)

File “install.py”, line 338, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/subprocess.py”, line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-e’,
‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2

and this is how i started my installation:

  1. apt-get update && apt-get upgrade
  2. apt-get install python-minimal
  3. apt-get install build-essential python-setuptools
  4. wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py
  5. python install.py --develop --user frappe //it throws the error here…
    • apt-get update && apt-get upgrade
    • apt-get install python-minimal
    • apt-get install build-essential python-setuptools
    • python install.py --develop

Use this it worked for me.

same error… :cry: :sob:

That’s strange, do you use sudo when issuing this commands?

no i use as a root user… then i was using open-ssh is their any way that this could be the reason why i cant properly install the erpnext???

You should never use root. MUCH safer to login as your frappe user and use sudo commands

1 Like

@cpsolution can you provide the entire trace log. It’ll be helpful to debug

i already find the issue… i just configure my static IP address of my server. But i installed only the development version i cant figure out how to get to master versions…

U can refer this