Email doesn't send with attachments

Hi team,
I tried to send email with attachments and it doesn’t work.
I set ERP on my own server, I added all Email settings(Email domain, Email Account) and when I send email without attachments everything works, when I send email with small attachments(under 100KB) it works too, but when I tried to send email with attachment’s size 300KB it doesn’t work, Email became status Sending and that’s all.
I changed max_file_size in site_config.json but nothing changed. Any help please?

1 Like

max_file_size defines what size of file user can upload to erpnext.

Emails queue status remains in sending state or it switches to errored after some time? If it switches to error please check your error logs for more details of the error.

Also, try to increase background workers

- In sites/comman_site_config.json update background workers count and save the file

- bench setup supervisor
- sudo supervisorctl reread
- sudo supervisorctl update

1 Like

hi, thank you very much for your answer.

Emails queue status only remains in sending state any errors(((

I increased background workers, didn’t help.

Hi @NMyshuk

Did you find a solution to this? We’re encountering the same issue!

Kind regards,

yes, there was the error with our server
we tried to install erpnext on the new server and everything is working now.

Thanks @NMyshuk

In our case, the size of attachments was above the limit set by the smtp service provider