Email Issues After Latest Update


Another issue with the latest updates with regards to email alerts or sending any sort of emails from the system.

Everything has stopped working and can’t receive or send any emails… Again, all was fine before i did the update…

Please help

Are you on develop or master? What versions are you on right now?


i am on master, using bench,

ERPNext: v6.27.10
Frappe Framework: v6.27.13

Do you see errors in “Bulk Email” or “Scheduler Log”? Can you make sure your email config is still working fine?

Hi all,

Same problem here. Trace below:

Traceback (most recent call last):
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 57, in application
response = frappe.handler.handle()
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 19, in handle
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 36, in execute_cmd
ret =, **frappe.form_dict)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 855, in call
return fn(*args, **newargs)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/core/doctype/communication/”, line 67, in make
comm.send(print_html, print_format, attachments, send_me_a_copy=send_me_a_copy)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/core/doctype/communication/”, line 160, in send
self.notify(print_html, print_format, attachments, recipients)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/core/doctype/communication/”, line 174, in notify
notify(self, print_html, print_format, attachments, recipients, cc, fetched_from_email_account)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/core/doctype/communication/”, line 115, in notify
recipients=recipients, cc=cc, lang=frappe.local.lang, session=frappe.local.session)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/utils/”, line 31, in enqueue
q = get_queue(queue)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/utils/”, line 125, in get_queue
return Queue(queue, connection=get_redis_conn())
File “/home/erpnext/frappe-bench/apps/frappe/frappe/utils/”, line 139, in get_redis_conn
raise Exception(‘redis_queue missing in common_site_config.json’)
Exception: redis_queue missing in common_site_config.json

@betabrain @ermalc can you do bench update once more?

Also if you are using supervisor, then try manually restarting the supervisor processes.


Thanks but did both and still the same problem. :no_mouth:

Any ideas?

@betabrain Can you try running bench setup config?

Tried that and now when I click email on any document nothing happens, no windows opens or anything.

Moreover, now any document I open shows blank with nothing on it. Tried doing another bench update with the same results.

If it helps, all of this is on the erpnext VM which has been running fine for the last 8 months with updates almost every week and no special customization.


Try bench build followed by bench clear-cache

Thanks but no luck. Did both and still the same result and blank pages.

I should note that if we do a PDF or pinto of the documents they show fine with all the info just on the screen is blank.


Hmm, this is very odd.

How about bench restart?

If you still get the same issue, could you open the console by doing CTRL + SHIFT + I and opening the Console tab, and paste whatever error you’re getting there, here?

Hi, same after restart.

The console is showing up a bunch of these errors:

[Error] Failed to load resource: the server responded with a status of 404 (NOT FOUND) (, line 0)


Hmm, I’m having trouble trying to pinpoint the issue

Try, bench setup socketio along with that can you paste the contents of your common_site_config.json in the sites folder here?

Here is goes:

erpnext@erpnext-vm:~/frappe-bench$ bench setup socketio
/bin/sh: 1: npm: not found
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==0.1’, ‘console_scripts’, ‘bench’)()
File “/home/erpnext/bench-repo/bench/”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click-3.3-py2.7.egg/click/”, line 610, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click-3.3-py2.7.egg/click/”, line 590, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click-3.3-py2.7.egg/click/”, line 936, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click-3.3-py2.7.egg/click/”, line 936, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click-3.3-py2.7.egg/click/”, line 782, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click-3.3-py2.7.egg/click/”, line 416, in invoke
return callback(*args, **kwargs)
File “/home/erpnext/bench-repo/bench/commands/”, line 77, in setup_socketio
File “/home/erpnext/bench-repo/bench/”, line 109, in setup_socketio
exec_cmd(“npm install redis express superagent cookie”, cwd=bench)
File “/home/erpnext/bench-repo/bench/”, line 99, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: npm install redis express superagent cookie


“auto_update”: false,
“frappe_user”: “erpnext”,
“rebase_on_pull”: false,
“redis_cache”: “redis://localhost:11311”,
“redis_queue”: “redis://localhost:6379”,
“redis_socketio”: “redis://localhost:12311”,
“restart_supervisor_on_update”: false,
“serve_default_site”: true,
“shallow_clone”: true,
“update_bench_on_update”: true

Hi all,

We did the latest update of today in hopes the blank screen would be fixed but no luck. Still the POs and other documents showing blank. Even when creating a new one we see nothing on the screen.

Any ideas?

Have you installed npm (?)