Email Settings are not working for outgoing email

I had set email account setting for my gmail account.Whenever I am sending any email the system is opening dialogue of email and later the confirmation message as email sent.But I don’t receive it in email account,I have checked spam folder too.

System emails are working like if I create a new user then he is getting welcome email instantly using same email account settings.

I have migrated from vr.4 to vr.5 too and have already tried updating again as per this thread,(,) but problem not solved.Kindly help !!

1 Like

I Also have same problem with email sent.
Email sent but I don’t Recive it in my email account

Can Any one please reply to this problem


1 Like

Emails are sent by background workers. Seems you have a scheduler that is not working

Check if your scheduler is running by doing bench doctor

I’m having the same problem. Emails are not going out.

I ran bench doctor and this is the result:

Workers online: True
Pending tasks 0
Timed out locks:

EDIT: Rebooting the VPS solved the problem. All the unsent emails went out. Any idea why, and what to add to the crontab so this problem doesn’t happen again?

I am having same problem, I solved this.

Please check frappe-bench/sites//locks folder, if there is scheduler lock file, delete file

run this command in frappe-bench folder

bench enable-scheduler
bench restart

check all process are running or not

sudo supervisorctl status

@kolate_sambhaji, thanks — there is no frappe-bench/sites//locks folder or frappe-bench/sites/locks folder

I wonder if the problem in my case was maybe that SMTP or some other mail-related program crashed?

@Peter you can find frappe-bench/your-site-name/lock folder

I had a timed out lock for FETCH_HEAD that was preventing emails from being processed. What could have caused this timed out lock?

I deleted the file directly from frappe-bench/your-site-name/lock/ since rebooting and restarting didn’t do it for me.

ikhlas@Ikhlas:~/sajid/frappe-bench$ bench restart
error: <class ‘xmlrpclib.Fault’>, <Fault 10: ‘BAD_NAME: frappe’>: file: /usr/lib/python2.7/ line: 794
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==0.92’, ‘console_scripts’, ‘bench’)()
File “/home/ikhlas/sajid/bench-repo/bench/”, line 60, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 700, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 680, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1027, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 873, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 508, in invoke
return callback(*args, **kwargs)
File “/home/ikhlas/sajid/bench-repo/bench/”, line 297, in restart
File “/home/ikhlas/sajid/bench-repo/bench/”, line 306, in restart_supervisor_processes
exec_cmd(cmd, cwd=bench)
File “/home/ikhlas/sajid/bench-repo/bench/”, line 105, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: sudo supervisorctl restart frappe:
ikhlas@Ikhlas:~/sajid/frappe-bench$ sudo supervisorctl status

Outgoing Mail is not send…I am have a same problem…

I removed the locker file and run the bench restart

when i sent an email its shows as

Email not sent to (unsubscribed / disabled)