Email won't be sent straight away, going to email queue instead

Manual send is necessary from queue after “not sent” shows.
Anyone has encountered this and can help out?


after clicking send now it sends

It takes 4mins for the system to clear the queue after you have generated a communication.
Next time, wait for 4mins and check if it doesn’t clear the queue. :slight_smile:

Hey @harshit-30 hi, thanks for the reply, nope it’s still not sent and option to send now from queue is still there.
Maybe something wrong with queue settings?
Nothing seems wrong on supervisor.conf

[program:frappe-bench-frappe-short-worker]
command=/usr/local/bin/bench worker --queue short
priority=4
autostart=true
autorestart=true
stdout_logfile=/home/frappe/frappe-bench/logs/worker.log
stderr_logfile=/home/frappe/frappe-bench/logs/worker.error.log
user=frappe
stopwaitsecs=360
directory=/home/frappe/frappe-bench
killasgroup=true
numprocs=1
process_name=%(program_name)s-%(process_num)d

also here’s what bench doctor spews with scheduler already enabledUntitled3

edit: pause scheduler set 0 now from 1.Untitled4

Edit, issue is fixed by deleting and adding same e-mail account.

having done what you have done there adding and deleting same account but still remaining in the status not sent

1 Like

having same issue did you find any solution??

@Bhatt_Aanal try bench --site site_name scheduler enable

I tried but still facing the same issue

This resolve for me

Go to - ERP Next Admin > Build > Background Jobs

and Check if RQ Job Scheduler is Active or Disabled.
if this is disabled.

and from Action “Enable Scheduler”

and this resolved the problem

1 Like