EmailAccount' object has no attribute 'no_smtp_authentication'

I am getting this error when trying to reauthenticate my email after upgrade to V11

Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 61, in application
response = frappe.handler.handle()
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 21, in handle
data = execute_cmd(cmd)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 56, in execute_cmd
return, **frappe.form_dict)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 1019, in call
return fn(*args, **newargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/desk/form/”, line 22, in savedocs
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 260, in save
return self._save(*args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 296, in _save
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 876, in run_before_save_methods
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 772, in run_method
out = Document.hook(fn)(self, *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 1048, in composer
return composed(self, method, *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 1031, in runner
add_to_return_value(self, fn(self, *args, **kwargs))
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 766, in
fn = lambda self, *args, **kwargs: getattr(self, method)(*args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/email/doctype/email_account/”, line 73, in validate
File “/home/frappe/frappe-bench/apps/frappe/frappe/email/doctype/email_account/”, line 137, in check_smtp
if self.password and not self.no_smtp_authentication:
AttributeError: ‘EmailAccount’ object has no attribute ‘no_smtp_authentication’

How can i fix this?

did you run bench update --patch?

Yes i did

Try executing following in the console (bench console):

frappe.reload_doc("email", "doctype", "email_account", force=True)

And then try again after clearing cache (bench clear-cache) and rebooting bench (bench restart).

1 Like

I executed and got this:

and then i ran a quick setup on my test VPS instance and found this in the email settings page:

I checked that box and my email configuration was saved successfully.
I checked the problem instance and found that this option does not exist:

My guess is this is where the issue is?

I’ve update my reply:

I’ve tried this and it gives me the syntax error: unexpected token “email”

You need to run in in bench console. Please read carefully.

sorry i missed that part. Ran it in bench console and issue resolved. Thanks a lot.

1 Like

This worked for me as well. My issue manifested after I switched from V11 dev to V11 master. Every 4 minutes I would have a error.

My problem was solved with this.
Thanks a lot.