Emails not sending automatically - Email "Date:" set to server RTC time not Local TimeZone

My emails are not sending automatically via the scheduler. They send correctly when I press the “Send Now” button in the email queue item.

I’ve checked all the logs and scoured this forum. I have found that the “Date:” of the message in the emails to be sent is set to RTC time, which is the past from the server system “local time”. There is a discrepancy in the following screen shots due to the time taking screenshots.

I’ve set the time zone properly in erpenxt settings and set up timedatectl on the server correctly.


Does the scheduler disregard sending emails that have a date in the past? The date thing might not be why the emails are not sending automatically via the scheduler but it is the only thing I have found as yet.


I’ve moved back to version-12 and it is working now. Have no idea why it wasn’t working on develop branch for me.

Now I need to know how to close this topic? :slightly_smiling_face:

anyone with the solution here so far am facing same problems here