Empty screen and can not login after installation

after successful installation I got screen with home , login cart
and the rest is empty , just links , and no link is work
i try with Ubuntu 16 , 18 and same happened .
i follow instructions exact . easy setup production mode.
no errors just screen empty screen with 3 links , it is clear no css is worked.

You’re basically describing the default website pages ERPNext gives you.

You can now add pages, links, image sliders etc from the Website module from backend.

maybe assets aren’t created yet. perhaps the following steps will help

  1. bench setup requirements --node
  2. bench build

Also, to access desk, you should try /desk which will prompt you to login

Of course I try /desk and login
The login boxes not showed to write user name and pass

the becnh build take long time with building frappe assets…
it quit it my self ,
any idea?

I reinstall using this https://computingforgeeks.com/how-to-install-erpnext-erp-system-on-ubuntu/

i got this error when bench init erpnex
WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench

$ /home/ahmed/.local/bin/virtualenv -q env -p python3
Traceback (most recent call last):
File “/home/ahmed/.local/lib/python2.7/site-packages/virtualenv.py”, line 22, in
import distutils.spawn
ModuleNotFoundError: No module named ‘distutils.spawn’
INFO:bench.app:Getting app frappe
$ git clone GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript --depth 1 --origin upstream
Cloning into ‘frappe’…
remote: Enumerating objects: 2840, done.
remote: Counting objects: 100% (2840/2840), done.
remote: Compressing objects: 100% (2647/2647), done.
remote: Total 2840 (delta 374), reused 1010 (delta 127), pack-reused 0
Receiving objects: 100% (2840/2840), 11.90 MiB | 9.62 MiB/s, done.
Resolving deltas: 100% (374/374), done.
INFO:bench.app:installing frappe
$ erpnext/env/bin/pip install -q -U -e erpnext/apps/frappe
[Errno 2] No such file or directory
ERROR: There was a problem while creating erpnext
Do you want to rollback these changes? [Y/n]:

this command solve the problem
sudo apt install python3-distutils -y
then i got another error for swaping ram
i do swaping file as here : javascript - Node.js catch ENOMEM error thrown after spawn - Stack Overflow

and bench init completed finally

1 Like

Hello and welcome to the forum.

I had similar issue during one of my presentation day before yesterday, it was clients conference laptop which I tried to use for presentation and it turned out that the antivirus was not allowed all the css to load as it was unsecured webpage.
I am not sure if it is the same for you.

Possible issues:

  • Browser not supported or very old. (Microsoft internet explorer wont work)
  • antivirus / firewall blocking the css to load.

Maybe you skipped these basic test before re-installing erpnext again.
Hope its fixed now.

thanks ,
it is fixed now but i facing another issue now.
can not run production setup
bench is never run any setup command

finally , I do the production setup without any error or stopper ,
I think the key was not create the user before running the script , just name the user and let the script do the job.
I make all the installation with root account
also, I downgrade the mariadb to 10.3 before setup

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.