Equity not shown in balance sheet

Hi all,

I have the following scenario: on ERPNext V10, I have a chart of accounts with the following nodes (extract)

  • Liability
    • Equity (group, root type liability) - amount 0 kUSD Dr
      • Equity (group, root type liability) - amount 100 kUSD Cr
        • Equity (account, type equity) - amount 100 kUSD Cr

The number of levels is derived from the local hierarchies.

Now my 2 questions:
(1) why is the second group node not calculating the amount (ledger on the account is correct and properly calculated on the first group level)
(2) on my balance sheet, there is only assets and liability. The equity is missing but reported as profit. I would expect assets = (liability + equity). Maybe this is a sub-issue from part 1 (because amount is 0)?

Side notes: the system was already migrated from v8 to v9 to v10. If I try to reproduce issue 1 on a fresh system, point one works but point 2 (no equity on balance sheet) is still the case.

Any inputs?

1 Like

When I recreated the same case on another system, it worked; however, on the affected system it remained. Only recreating the whole chart of accounts and creating new journal entries resolved the issue. I could not find any difference in any settings other than the account number now being a separate field rather than part of the name…

I have been facing the exact same issue on my system. I recently ported my server and General Ledger had all zeros. In order to check the error I installed ERPNext on my local machine and I could see all the values there. No difference in the branches. Have tried to update the system check the values at different levels in the program have not been able to find anything. I have posted the same on the forum but to no avail Reports are blank - #5 by tmatteson.