ERPNext 14: Error message when adding or modifying DocType

Hello everyone

I suddenly had a problem…

Create a module called “demo_dotype”
Then I created an app called “taha” inside the module.
Then I created a DocType inside app and things fell into place
Then, after that, I created a new DocType and saved it. I got the error message shown at the bottom of this problem
And then the DocTypes that I created in the same module show the same error message

Please anyone who encountered this error or any expert friend help in solving the error problem


1 Like

Hello @TahaAtiah ^ ^

I think the main problem of this error message you mentioned, is in the router process… that frappe can’t locate your model/doctype, and open it…

There are a few potential reasons why this error message may appear:
you can start with:

  • Check if it is Missing or incorrectly Created model:
  • Check whether Module not enabled: (from User master, in “Allow Modules” section)…
  • Check if it is related to permissions issue: (ensure that currentuser has the appropriate roles and permissions assigned to access the model)…
  • Maybe you just need to run bench restart and bench clear-cache

Hope this helps…

Hi @MohamedAbdulsalam

I have tried all the steps of the experiment, but the problem has not been solved.

Is there any other method to solve it or to avoid such problems??

Hy @TahaAtiah

You can check by opening a new site and installing the module
If the error occurs again, check that your module does not have that doctype

Thank You!

@TahaAtiah In “Doctype” Master, of your app “hotel_app”
Go To: “Permission Rules” Section ,
Check the “Restrict To Domain” field to see if the doctype is restricted to a specific domain.
If it is restricted to domains,
You can delete the field, or go to Domain Settings, and activate the domain…