ERPNext Desk stuck at Logo in Production

All of a sudden, I can’t access the desk and it is stuck on the logo, I’ve set it up on an Ubuntu 20.04 server in production mode. I’ve tried bench migrate and bench update as well.

Errors in chrome console are:

Point to note here is the desk doesn’t work when accessed through the set domain but the whole desk works fine through http://serverIp:8000/app.

Not sure, but you can try setting hostname in your site config and then run bench build

The thing is I’ve recently installed ERPNext on two servers with same procedure and it’s working on one but not on this one I intended to use as a dev server. I reinstalled the whole Ubuntu and ERPNext after formatting the server and it started working but again, it is stuck on the logo. And your solution doesn’t work either. It is up and running, I can access the site but the desk is stuck on the logo, it was absolutely fine yesterday when I reinstalled it.

And, it’s been more than a month since I’ve been trying to set up an open-source ERP, ERPNext or Gauzy but support is very limited I’d say.

Could you share the output of bench build command?
And also screenshot of the site config.

See here for the log and other details.

Any solutions or no one cares?

Use these below Command

sudo chown -R frappe:frappe *

bench update --reset

If not solve pls check hardware requirements for ERPNext.

Hey @netmanthan , In the span of two months messing with ERPNext, I’ve noticed commands like update or reinstall doesn’t work with bench after installing it and such commands show an error related to bleach-whitelist package and installing the package using pip doesn’t help.

But, I managed to find a solution, the problem was in bench and not in ERPNext which is why none of the solutions intended for ERPNext worked. I reinstalled specific stable version 13 of bench and have not faced any issues till then. Hope this helps some other user.

You need to install it in the virtual envirunment.
Go to you bench folder and then run env/bin/pip install bleach-whitelist

I also have the same issue.
Development setup
frappe and erpnext versions: v13.25.0

Please help, I have same exact issue as you. Can you please specify which code you use to “specific stable version 13 of bench”. As far as today, bench is v5.14.0. Do you mean by specific stable version 13 of frappe?

I have a suggestion, but because I’ve been posting the same answer in different threads, it actually won’t let me post it, so I’ve added this sentence here to try get around the forum from allowing me to post an idea, here’s my idea…

Do you have a minification process, such as Cloudflare’s auto minify feature or a proxy that removes sourceMappingUrl values from the end of the JS bundle files?

Good luck