ERPNext Error on Upgrade v14 to v15 for Redis Cache and Queue

On my local VM, I am running a close to out-of-the-box ERPNext instance.

I upgraded from v14 to v15 and everything went fine until the last part where I ran the command sudo supervisorctl restart all and the log returned the following errors:

frappe-bench-redis:frappe-bench-redis-cache: ERROR (spawn error)
frappe-bench-redis:frappe-bench-redis-queue: ERROR (spawn error)

The site is running, but this is concerning for me as this is a production instance and I want to understand what impact this will have for the end-user.

These are the installed apps on the instance at the moment:
ERPNext: v15.0.0 (version-15)
Frappe Framework: v15.1.0 (version-15)
Frappe HR: v16.0.0-dev (develop)
Payments: v0.0.1 (develop)
Persona: v0.0.1 (main)

I ended up fixing the error.

Root Cause
Found in bench/logs for both redis_cache.log and redis_cache.log files.

Could not create server TCP listening socket *:6379: bind: Address already in use     

I think I made the breaking changes in a previous installation of v14 where the fix was to set the socket values as such.


  • Navigate to bench/config
  • Modify the redis_cache.conf and redis_queue.conf files by changing the ports to different values (such as 13000 and 11000 respectively – which are the values found in the frappe repo frappe/utils/
  • Save the files after changing the port values.
  • Run sudo supervisorctl restart all
  • Confirm the services are all started without errors.

I used these stack overflow posts for reference when solving this issue.

Just a follow up since I found this error on my instance, which may be related to the above.

Certbot Service Failed
I found that my snap.certbot.renew.service was in a failed status when I ran sudo systemctl status.

To solve this, I ran sudo systemctl reset-failed and flipped the status back to active.