Erpnext hitchhiker's guide setup error

erpnext hitchhiker’s guide setup error

I have tried the mentioned setup everything went smooth up to this
$ pip install -e ./bench
after this command i got this error which i could not find a solution for on the forums.

Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: ‘/usr/local/lib/python2.7/dist-packages/Click-7.0.dist-info’
Consider using the --user option or check the permissions.

I am not very knowledgeable with linux and or erpnext as nothing has really been working out for me, nothing has worked 100% so far for erpnext, its one thing or the other, something always fails to work.
full details of this command is below

user1@user1-G41D3C:~$ pip install -e ./bench
Obtaining file:///home/user1/bench
Collecting Click (from bench==4.1.0)
Using cached
Collecting jinja2 (from bench==4.1.0)
Using cached
Collecting virtualenv (from bench==4.1.0)
Using cached
Collecting requests (from bench==4.1.0)
Using cached
Collecting honcho (from bench==4.1.0)
Using cached
Collecting python-crontab (from bench==4.1.0)
Collecting semantic_version (from bench==4.1.0)
Collecting GitPython== (from bench==4.1.0)
Collecting MarkupSafe>=0.23 (from jinja2->bench==4.1.0)
Collecting certifi>=2017.4.17 (from requests->bench==4.1.0)
Using cached
Collecting chardet<3.1.0,>=3.0.2 (from requests->bench==4.1.0)
Using cached
Collecting urllib3<1.24,>=1.21.1 (from requests->bench==4.1.0)
Using cached
Collecting idna<2.8,>=2.5 (from requests->bench==4.1.0)
Using cached
Collecting python-dateutil (from python-crontab->bench==4.1.0)
Using cached
Collecting gitdb>=0.6.0 (from GitPython==>bench==4.1.0)
Collecting six>=1.5 (from python-dateutil->python-crontab->bench==4.1.0)
Using cached
Collecting smmap>=0.8.5 (from gitdb>=0.6.0->GitPython==>bench==4.1.0)
Installing collected packages: Click, MarkupSafe, jinja2, virtualenv, certifi, chardet, urllib3, idna, requests, honcho, six, python-dateutil, python-crontab, semantic-version, smmap, gitdb, GitPython, bench
Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: ‘/usr/local/lib/python2.7/dist-packages/Click-7.0.dist-info’
Consider using the --user option or check the permissions.

for this particular command, you need to add sudo otherwise it gives trouble

sudo pip install -e ./bench

alright thanks, such a simple issue :slight_smile:

it did nto work, now it says about owner ship and -H, no cashe dir now.

I have managed to sort it out now, got a working install now.

ran all of it with sudo -i untill bench and then switch to normal $ and continue to follow the instructions. it worked.

This sequence works for me…

#Login as #########frappe########## user
su frappe && cd ~
git clone GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps bench-repo
##pip install --user -e bench-repo (I cannot get this part to work properly)
sudo pip install -e bench-repo