ERPNext is not working. Showing error like "User Guest not found"

I just tried to setup erpnext 12 in my local. But it is not working showing error like User Guest not found. How can i rectify this ??


Hi @rajeeb,

I am encountering a similar issue as above.

Have you been able to resolve the above?

Best regards,

I have similar behavior with email digest caused this error, you can do:
sudo supervisorctl restart all


bench update

While executing bench update, I get this error:

Executing erpnext.patches.v11_0.rename_production_order_to_work_order in site1.local (_1bd3e0294da19198)
rename_field: work_order not found in Timesheet
Traceback (most recent call last):
File “/usr/lib/python3.6/”, line 193, in _run_module_as_main
“main”, mod_spec)
File “/usr/lib/python3.6/”, line 85, in _run_code
exec(code, run_globals)
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 97, in
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 18, in main
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/click/”, line 764, in call
return self.main(*args, **kwargs)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/click/”, line 717, in main
rv = self.invoke(ctx)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/click/”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/click/”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/click/”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/click/”, line 555, in invoke
return callback(*args, **kwargs)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/click/”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 25, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 233, in migrate
migrate(context.verbose, rebuild_website=rebuild_website, skip_failing=skip_failing)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 48, in migrate
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 41, in run_all
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 30, in run_patch
if not run_single(patchmodule = patch):
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 71, in run_single
return execute_patch(patchmodule, method, methodargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 91, in execute_patch
frappe.get_attr(patchmodule.split()[0] + “.execute”)()
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/patches/v11_0/”, line 22, in execute
rename_field(“Stock Entry”, “production_order”, “work_order”)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/utils/”, line 35, in rename_field
(doctype, new_fieldname, old_fieldname))
File “/home/frappe/frappe-bench/apps/frappe/frappe/database/”, line 171, in sql
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pymysql/”, line 170, in execute
result = self._query(query)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pymysql/”, line 328, in _query
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pymysql/”, line 517, in query
self._affected_rows = self._read_query_result(unbuffered=unbuffered)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pymysql/”, line 732, in _read_query_result
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pymysql/”, line 1075, in read
first_packet = self.connection._read_packet()
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pymysql/”, line 684, in _read_packet
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pymysql/”, line 220, in check_error
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pymysql/”, line 109, in raise_mysql_exception
raise errorclass(errno, errval)
pymysql.err.InternalError: (1054, “Unknown column ‘production_order’ in ‘field list’”)

What should I do ?

To All,
Same issue after fresh install on Ubuntu 18.04 using script. Help much appreciated.


How did you manage to install on 18.04 :joy: many of us are here tryna get it installed in first place :stuck_out_tongue_winking_eye:

@iMoshi i: I lost track since I tried it 3 to 4 times haha. But the last one I just gave up installing manually and just used easy install. Ran into an error and I apologize but I forgot which one but it was during Ansible portion … vaguely remembered something about utf8 character set but found a thread that fixed it … and just reran easy install one last time and it completed.

Of course, when you try to get in from the browser, we get the infamous “User Guest not Found”. So on to Bench Update to see if it’s patched, and ran into same error as @Devesh_Naga “Unknown Column ‘production_order’ in 'field list”, and here we are. Guess have to wait until someone patches it.


@iMoshi ok here we go. I just started over, and followed this thread

But let me summarize.

Bring up your Ubuntu 18.04 VM
Do not perform update (i.e. sudo apt-get update / sudo apt-get upgrade)
sudo apt install python-minimal
sudo python --production --user frappe
(mariadb password and admin password)

And it completed all the way thru and I got it up finally.

Hope it works out for you!!


Right, they’ve fixed the bench installer very recently :slight_smile:

I really really wanted to congratulate the Frappe team, but then thought well they already know :slight_smile:

To All,

I am facing the same issue after a fresh install on WSL Ubuntu 18.04 using the steps in this article: [Tutorial] How To install ERPNext V12 on windows 10 home / Pro WSL ubuntu 18.04LTS

The only thing I did differently was to setup supervisor and nginx as stated in “Setup Production” guide of the Easy Install Script.

Any help is appreciated.


To All,


  1. I tried skipping the setup of Supervisor and Nginx as stated in the “Setup Production” guide of the Easy Install Script but it led to “localhost does not exist” or some such error when I tried to access the website.

  2. I tried the solution mentioned by @youssef but it did not help.

  3. I tried the solution mentioned by @Akram_Mutaher but it did not help.

  4. I tried the solution mentioned by @cphoa28 but it did not help.


  1. I do not get any error while using bench update when I already have a bench start running in a separate terminal.

I have been stuck on this error in WSL install for the past three weeks. I have tried resetting the WSL Ubuntu 18.04 and reinstalling ERPNext multiple times but to no avail.

I would rather run ERPNext on WSL than VM or docker.

Any help is appreciated.


hi, so how do you solve that error?