ERPNext keeps failing and then works when I restart the EC2 instance ( atleast i think thats the case ) - prod

I am using v13, I am just setting up for the first time.
I have been using it over a week now, we are testing workflows and understanding how to use for our organisation.

Wondering if i should rollback to v12, and then later move to 13.

Couple of things i have noticed:

  • the platform stops being responsive, and throws ERR_CONNECTION_TIMED_OUT

  • i tried restarting the instance a couple of times, was not able to fix it

  • was looking at the nginx etc, it seemed fine,

  • after a while i was able to use the platform again

  • and after an hour or two, i was creating creating a job application for external users, and seeing how that goes, and it just said invalid error, i tried a few combinations, and said the same, refreshed it and then the same issue has happened

I want to understand which all error logs should be looked into in a step by step fashion to understand the debugging process.
I basically want to know how to identify the issues.

I have done some custom doc type changes, and some form changes FYI.

Its working now again, i had rebooted EC2 instance, and after a while its working.
can I know where to debug these issues?