ERPNext not responding

ERPNext will not respond. When I go to the server where it is installed and has been running for a month has suddenly stopped working. Now when I go to the web address I get a website is not responding error. I have tried restarting the server and restarting from bench. Neither has worked. Anyone have an idea how to fix this?

You need to share an error message if you want some help.

Maybe start with pinging your server if it is up.

@rmehta There is no error message to post. Erpnext will no longer come up when I go to the web address. It appears that the CPU maxed out at the time the issue happened. The cpu activity is now pretty much flat lined. I have tried restarting the server and bench restart. Nothing has worked.

PING ( 56(84) bytes of data.

— ping statistics —
5 packets transmitted, 0 received, 100% packet loss, time 4030ms

login to server and put output of following command.

sudo supervisorctl status
sudo supervisorctl restart all

Also open browser and send console message if any.

@kolate_sambhaji I have ran the commands as suggested but it has not solved the issue. Also the browser does not display any message in the console.

Using username "ubuntu".
Authenticating with public key "imported-openssh-key"
Welcome to Ubuntu 16.04.2 LTS (GNU/Linux 4.4.0-1041-aws x86_64)

 * Documentation:
 * Management:
 * Support:

  Get cloud support with Ubuntu Advantage Cloud Guest:

76 packages can be updated.
0 updates are security updates.

Last login: Wed Nov 29 15:51:31 2017 from 172.**.***.***
ubuntu@ip-172.**.***.***:~$ cd ../frappe/frappe-bench
ubuntu@ip-172.**.***.***:/home/frappe/frappe-bench$ sudo supervisorctl status
frappe-bench-redis:frappe-bench-redis-cache                 RUNNING   pid 8461, uptime 0:05:05
frappe-bench-redis:frappe-bench-redis-queue                 RUNNING   pid 8460, uptime 0:05:06
frappe-bench-redis:frappe-bench-redis-socketio              RUNNING   pid 8462, uptime 0:05:05
frappe-bench-web:frappe-bench-frappe-web                    RUNNING   pid 8458, uptime 0:05:06
frappe-bench-web:frappe-bench-node-socketio                 RUNNING   pid 8459, uptime 0:05:06
frappe-bench-workers:frappe-bench-frappe-default-worker-0   RUNNING   pid 8455, uptime 0:05:06
frappe-bench-workers:frappe-bench-frappe-long-worker-0      RUNNING   pid 8456, uptime 0:05:06
frappe-bench-workers:frappe-bench-frappe-schedule           RUNNING   pid 8454, uptime 0:05:06
frappe-bench-workers:frappe-bench-frappe-short-worker-0     RUNNING   pid 8457, uptime 0:05:06
ubuntu@ip-172.**.***.***:/home/frappe/frappe-bench$ sudo supervisorctl restart all
frappe-bench-workers:frappe-bench-frappe-schedule: stopped
frappe-bench-web:frappe-bench-node-socketio: stopped
frappe-bench-redis:frappe-bench-redis-queue: stopped
frappe-bench-redis:frappe-bench-redis-cache: stopped
frappe-bench-redis:frappe-bench-redis-socketio: stopped
frappe-bench-workers:frappe-bench-frappe-default-worker-0: stopped
frappe-bench-workers:frappe-bench-frappe-long-worker-0: stopped
frappe-bench-workers:frappe-bench-frappe-short-worker-0: stopped
frappe-bench-web:frappe-bench-frappe-web: stopped
frappe-bench-workers:frappe-bench-frappe-schedule: started
frappe-bench-workers:frappe-bench-frappe-default-worker-0: started
frappe-bench-workers:frappe-bench-frappe-long-worker-0: started
frappe-bench-workers:frappe-bench-frappe-short-worker-0: started
frappe-bench-web:frappe-bench-frappe-web: started
frappe-bench-web:frappe-bench-node-socketio: started
frappe-bench-redis:frappe-bench-redis-queue: started
frappe-bench-redis:frappe-bench-redis-cache: started
frappe-bench-redis:frappe-bench-redis-socketio: started

Your server supervisor and server is working fine.
Are you able to login using

@kolate_sambhaji It must have taken a while. It appears to be working now. Thank You.

1 Like