ERPNext persistent Installation Issues

Hello there,

I am having same issues installing on a DigitalOcean VPS…I have tried all suggestions here and having same issues.

Is there anything else that could be done.

can you post text of the error (including the red text)?

The --become-user errors are almost always related to the installer attempting to run from the same user account that it is trying to install into.

I you login as root to the server and then run the install using the --user switch to define the user account you want it to install into, this has always fixed it for me even on digital ocean.


1 Like

It will also be nice to see your full traceback if as you said, you followed the suggested process. One issue i noted last time i installed was with wkhtmltopdf failing to download due to slow connection and had nothing to do with the actual setup script.

Thanks. Yes as you noted it does appear to be an issue with my ISP as some other unrelated processes i was running timeout. I did however find another install route with this which worked perfectly.

Thank you @bkm . This helped with some earlier install issues but i just couldnt get past the last. As @flexy2ky noted my ISP may be the culprit here.

I faced the same issue in Ubuntu 18.04.4. I followed the suggestion to install wkhtmltopdf separately. But that was also failing with Connection failed [IP: 80]
After dist-upgrade and reboot, I could successfully complete the installation. The complete steps I followed:

$ sudo useradd -d /home/frappe -s /bin/bash -m frappe
$ sudo passwd frappe
$ sudo adduser frappe sudo
$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get dist-upgrade
$ sudo reboot

$ sudo apt-get install python3-minimal build-essential python3-setuptools python-pip
$ sudo apt-get install xvfb libfontconfig wkhtmltopdf
$ wget
$ sudo python3 --production --user frappe