ERPnext | Production Setup | Ubuntu 18.04

I am very new to New to ERPNext.
Tried to install production setup.
Encountered below error. Ubuntu 18.04, Python3. All other steps are completed successfully.

fatal: [localhost]: FAILED! => {
“changed”: false,
“invocation”: {
“module_args”: {
“allow_change_held_packages”: false,
“allow_downgrade”: false,
“allow_unauthenticated”: false,
“autoclean”: false,
“autoremove”: false,
“cache_valid_time”: 0,
“clean”: false,
“deb”: null,
“default_release”: null,
“dpkg_options”: “force-confdef,force-confold”,
“fail_on_autoremove”: false,
“force”: false,
“force_apt_get”: false,
“install_recommends”: null,
“lock_timeout”: 60,
“name”: “fail2ban”,
“only_upgrade”: false,
“package”: [
“policy_rc_d”: null,
“purge”: false,
“state”: “present”,
“update_cache”: null,
“update_cache_retries”: 5,
“update_cache_retry_max_delay”: 12,
“upgrade”: “no”
“msg”: “python3-apt must be installed and visible from /usr/bin/python3.”

PLAY RECAP ****************************************************************************************************************************************
localhost : ok=1 changed=0 unreachable=0 failed=1 skipped=1 rescued=0 ignored=0

ERROR: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘{“production”: true, “admin_emails”: “”, “mysql_root_password”: null, “container”: false}’, ‘-t’, ‘fail2ban’]’ returned non-zero exit status 2.

Not sure what went wrong!!

Please guide


can you execute sudo apt install python3-apt and rerun the same production setup command(sudo bench setup production)?

The “msg” says that python3-apt is missing and hopefully installing that might resolve the problem :smiley:

Same error here. However, I have python3-apt installed. I am not sure what to do.
I have removed and re-installed it, but still getting the same error.