ERPNext-Production_v14.8.0 ova download link

Here is download link for ERPNext Production V14.8.0 OVA

ERPNext-Production_v14.8.0_hr_pr.ova

Import in Open VirtualBox and enjoy. :blush:
Ubuntu_server: 22.04.1 LTS
Ubuntu Login : frappe
Password : frappe
mySQL : frappe

10 Likes

@hafiz4saqib
Thank you!
Work like as charm …

1 Like

Many thanks for this. It’s running nicely. My problem is that I can’t work out how to stop it :slight_smile:

I am trying to debug against it using VS Code. But when VS Code tries to start Bench it complains that there is already something on port 8000… which of course there is. But when I kill all the processes on port 8000 they just come back again.

Do you mind pointing me in the right direction either to stop the Bench from starting when the server starts or how to stop the Bench after it has started.

(I did find a thread lamenting the fact that there is no ‘bench stop’ command. This feels like something that would be really helpful right now.)

OK, i have worked it now.

The file /home/frappe/frappe-bench/config/supervisor.conf
needs the gunicorn command modified

autorestart=false.

I also set autostart=false so that I didn’t need to kill it.

1 Like

@Andrew_Rogers
By the way why do you need to stop service of supervisor ? :sweat_smile:

Yeah, normally my problem is getting things to go. This time it was getting things to stop :slight_smile:

To debug the code in Visual Studio Code, VS Code needs to start the main Bench process so it can connect to it. But it couldn’t start it because port 8000 was already being used.

1 Like

Hello guys,
I’m rather new to this and I’m tryna access ERP Next on my machine but im stuck at this window below.


How can I get to the login page? I tried typing in the IP address shown in the photo in my chrome search bar but it didn’t work. Please somebody help me

It looks like you have configured the Virtual Box to use the NAT adapter type (the IP address starts with 10.0). That can work but it is more complicated. Try setting the adapter to Bridged mode. You should then see an IP address that is on your network (maybe 192.168…).

Then point your browser at that address.

Thank you for responding, appreciate it!

It is true that I set my adapter type to NAT initially. But even after following your advice and switching it to bridged it still shows the same IP. Perhaps restarting my device could help?

@Ramy
Try these settings and checkout …

And check ip address via

ifconfig

2 Likes

This worked, thank you.

Now how do I obtain login credentials? I don’t have a frappe account

1 Like

@Ramy Happy to hear that this method worked … :star_struck:
By default Frappe Login = Administrator and Password = admin like as shown in picture.

1 Like

Giving me import appliance error . refer screenshot

@Abdullah_A_Ansari
Here are 2 scenarios.
1:- Check your CPU is this supported Virtualization or no ?
if NOT then OVA will not work.

2:- If answer is YES then Enable it.
Easy way to check in windows 10 like as below from Task Manager

Hi Saqib

I have checked Virtualization is enabled in my win10. In fact the version 13 i am using currently is imported ova.

@Abdullah_A_Ansari
Then you should delete .VirtualBox folder from current user account.

vbox-folder

Restart system and retry to import ova.

Thanks for response. but same issue. I guess if you re upload the ova then i may try to import once again.

@Abdullah_A_Ansari
Try with VMware Workstation Player
https://download3.vmware.com/software/WKST-PLAYER-1700/VMware-player-full-17.0.0-20800274.exe

Hi Hafiz, I tried every way. but i believe some problem with my PC configuration. Its still showing same error in import. Anyways, will try on other PC, thanks for your Help all the Way…!!

@hafiz4saqib network configuration problem vmware player.