ERPNext site not found

I installed ERPNext using the docker easy script. The installation seems to be successful, I didn’t see any bugs or problems pop up.
However when I load the site it says
Not Found
medicatech does not exist

not sure really how to fix that I deleted and reinstalled the containers multiple times. I did run the command correctly and it output both database and admin password

This is using docker so I am not too familiar with it I have no idea where to find the log file or what to do to get this running

anyone can help?

you should use the exact domain name that’ll be used for site to create new site

e.g. if you wish to visit then you’ve to create site called

That is exactly what I did here is the easy script command I used let me know if messed anything up

sudo python3 --prod --sitename --project medicatech --email

is this correct?

try to visit the ip address of the server. is it showing 404 page not found?

if server shows some page then, is DNS configured? your site subdomain should point to that ip.

if that works then letsecrypt certificate is generated and everything works

the site not found error is from the ip address, it also displays the same error for the url.

I also already setup the dns settings for the subdomain and tested it and it works fine

any other suggestions as to why I am getting this error and how can I fix it?

I reinstalled everything again from scratch and it seems to have worked looks like it was a linux permission issue