ERPNext Update from V11 to Version 12

Hello team i, i have update the frappe from V11 to V12, but i am unable to update erpnext from V11 to V12. I went through with many links but didnt get exact solution
Switching for erpnext
INFO:bench.utils:git config --unset-all remote.upstream.fetch
INFO:bench.utils:git config --add remote.upstream.fetch ‘+refs/heads/:refs/remotes/upstream/
INFO:bench.utils:git fetch upstream
fatal: ‘upstream’ does not appear to be a git repository
fatal: Could not read from remote repository.

Error switching to branch version-12 for erpnext
Updating Python libraries…
INFO:bench.utils:./env/bin/pip install --upgrade pip

#Error switching to branch version-12 for erpnext
Successfully switched branches for:

erpnext 11.1.62
frappe 12.0.13

Please help me out for updating only erpnext

What does this show

cat ~/frappe-bench/apps/erpnext/.git/config | grep -i refs

It showed this

# merge = refs/heads/version-12
# fetch = +refs/heads/:refs/remotes/upstream/
fetch = +refs/heads/:refs/remotes/upstream/

go to the erpnext app folder, run this command:

git config remote.upstream.fetch "+refs/heads/*:refs/remotes/upstream/*"

and then run bench switch-to-version 12 from frappe-bench folder.


It has “lost” the /master or /* markers, which is why the update is failing

Thanks @trentmu for replying , but how to solve this ?

@kennethsequeira tried but didnt worked

Have a look at this post…
It seems the quotes in the .git config are causing a mismatch?

Thank you so much :slight_smile: