ERPNext Virtual Machine not working on Macbook

I was using ERPNext using a virtual machine image on my mac, but for the last few days when I visit localhost:8080, it only shows It works!.
Can anyone tell me what’s the issue?


P.S. Screenshot is attached

That does not look like an ERPNext error message.

It looks like an Apache virtual host placeholder page.

Have you tried http://localhost:3000/

Yes. I have tried to visit http://localhost:3000/ but it only shows that this site can not be reached.

Could you show here your web server configuration?

I haven’t changed anything. I’m using virtualbox and virtual image (production).
Everything was perfectly fine and working.

When I want to use ERPNEXT First i open virtualbox then start production image and just visit http://localhost:8080 on my mac.

I haven’t changed any kind of settings.

Did you make a snapshot that you can revert to?

No. I didn’t make snapshot.

I would try to login to your server with the frappe user and then run the 2 commands below

  1. cd ~/frappe-bench
  2. bench restart
  3. try again to access the instance in your browser
  • the first command moves you into the correct folder where you can execute bench commands
  • the second restarts the entire frappe/erpnext stack