ERPNext was not upgraded


I have these versions:

ERPNext: v11.1.56 (version-11)

Frappe Framework: v11.1.52 (version-11)

I have used this command in SSH console:

bench update --patch

This was the output.

frappe@vps [~/frappe-bench]# bench update --patch
remote: Enumerating objects: 6198, done.
remote: Counting objects: 100% (6198/6198), done.
remote: Compressing objects: 100% (59/59), done.
remote: Total 17303 (delta 6155), reused 6166 (delta 6139), pack-reused 11105
Receiving objects: 100% (17303/17303), 15.90 MiB | 371.00 KiB/s, done.
Resolving deltas: 100% (13134/13134), completed with 1017 local objects.
From GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript
aa0e0f647…80f666789 version-11 → upstream/version-11

  • [new branch] breadcrumb-schema-org → upstream/breadcrumb-schema-org
    5f389b8db…2e2c038f3 develop → upstream/develop
    c3a8454fb…6d673d70b v10.x.x → upstream/v10.x.x
  • [new branch] v11-pre-release → upstream/v11-pre-release
  • [new branch] v12-pre-release → upstream/v12-pre-release
    e6ff0ae63…4c111507f version-11-hotfix → upstream/version-11-hotfix
    175818675…5aa81ee77 version-12 → upstream/version-12
  • [new branch] version-12-hotfix → upstream/version-12-hotfix
  • [new tag] v11.1.64 → v11.1.64
  • [new tag] v12.2.1 → v12.2.1
  • [new tag] v11.1.53 → v11.1.53
  • [new tag] v11.1.54 → v11.1.54
  • [new tag] v11.1.55 → v11.1.55
  • [new tag] v11.1.56 → v11.1.56
  • [new tag] v11.1.57 → v11.1.57
  • [new tag] v11.1.58 → v11.1.58
  • [new tag] v11.1.59 → v11.1.59
  • [new tag] v11.1.60 → v11.1.60
  • [new tag] v11.1.61 → v11.1.61
  • [new tag] v11.1.62 → v11.1.62
  • [new tag] v11.1.63 → v11.1.63
  • [new tag] v12.0.10 → v12.0.10
  • [new tag] v12.0.11 → v12.0.11
  • [new tag] v12.0.12 → v12.0.12
  • [new tag] v12.0.13 → v12.0.13
  • [new tag] v12.0.14 → v12.0.14
  • [new tag] v12.0.15 → v12.0.15
  • [new tag] v12.0.16 → v12.0.16
  • [new tag] v12.0.17 → v12.0.17
  • [new tag] v12.0.18 → v12.0.18
  • [new tag] v12.0.19 → v12.0.19
  • [new tag] v12.0.20 → v12.0.20
  • [new tag] v12.0.21 → v12.0.21
  • [new tag] v12.0.9 → v12.0.9
  • [new tag] v12.1.0 → v12.1.0
  • [new tag] v12.2.0 → v12.2.0
    Backing up sites…
    Patching sites…
    Migrating erp.desytec
    Updating DocTypes for frappe : [========================================]
    Updating DocTypes for erpnext : [========================================]
    INFO:bench.utils:sudo supervisorctl restart frappe-bench-workers: frappe-bench-web:
    frappe-bench-workers:frappe-bench-frappe-schedule: stopped
    frappe-bench-workers:frappe-bench-frappe-default-worker-0: stopped
    frappe-bench-workers:frappe-bench-frappe-long-worker-0: stopped
    frappe-bench-workers:frappe-bench-frappe-short-worker-0: stopped
    frappe-bench-web:frappe-bench-node-socketio: stopped
    frappe-bench-web:frappe-bench-frappe-web: stopped
    frappe-bench-workers:frappe-bench-frappe-schedule: started
    frappe-bench-workers:frappe-bench-frappe-default-worker-0: started
    frappe-bench-workers:frappe-bench-frappe-long-worker-0: started
    frappe-bench-workers:frappe-bench-frappe-short-worker-0: started
    frappe-bench-web:frappe-bench-frappe-web: started
    frappe-bench-web:frappe-bench-node-socketio: started

Bench: Deployment tool for Frappe and ERPNext (
Open source depends on your contributions, so please contribute bug reports, patches, fixes or cash and be a part of the community

All above was done with ERPNext logged in. Suddenly, the page notified me the framework was updated and I needed to refresh the page, what I did.

After that, I saw that the same version are still there.

I have also tried by logging off and then log on, and the same happens.

What is missing?


Hey @Jaime_Stuardo, as of mentioned in the Bench cheatsheet, bench update --patch runs only migrations for all sites in that bench. Have you tried running a vanilla bench update instead?