[ERPNextv5] AttributeError: 'NoneType' object has no attribute 'group'

We are facing below error, at the time of start the application since 16/07/18 morning.
Till date application running well locally.

[admin@localhost frappe-bench]$ bench start
Traceback (most recent call last):
  File "/usr/bin/bench", line 9, in <module>
    load_entry_point('bench==0.92', 'console_scripts', 'bench')()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 378, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2566, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/home/admin/Public/mycfoProject/bench_repo/bench/cli.py", line 2, in <module>
    from .utils import init as _init
  File "/home/admin/Public/mycfoProject/bench_repo/bench/utils.py", line 622, in <module>
    FRAPPE_VERSION = get_current_frappe_version()
  File "/home/admin/Public/mycfoProject/bench_repo/bench/utils.py", line 463, in get_current_frappe_version
    from .app import get_current_frappe_version as fv
  File "/home/admin/Public/mycfoProject/bench_repo/bench/app.py", line 209, in <module>
    FRAPPE_VERSION = get_current_frappe_version()
  File "/home/admin/Public/mycfoProject/bench_repo/bench/app.py", line 107, in get_current_frappe_version
    return get_major_version(get_current_version('frappe', bench=bench))
  File "/home/admin/Public/mycfoProject/bench_repo/bench/app.py", line 122, in get_current_version
    return get_version_from_string(f.read())
  File "/home/admin/Public/mycfoProject/bench_repo/bench/app.py", line 191, in get_version_from_string
    return match.group(2)
AttributeError: 'NoneType' object has no attribute 'group'

Try again after bench update?

Hello Schilgod,

I have run the bench update command, it showing the same error.
We have read about the error it lead us to “Python + Regex”, are we on right track?

Please suggest what we can do to resolve this kind of errors.

We have refer below references try to resolve the issue, but nothing help us out.

Thank You.


I tried to clone the new repo from github, It leads me to error.

AttributeError: ‘NoneType’ object has no attribute ‘group’

Hello schilgod,

Well I have ERPNext version 5 application with me. We do not have any plan to migrate now.

I have resolve the above error then setup the configuration part i.e (redis, procfile and socketio)
Reference: Regenerate Production Config Files (ERPNext) · frappe/bench Wiki · GitHub

We are new to ERPNext development, please help us out to fix the below error.

Error: Cannot find module '/home/admin/Public/frappe/socketio.js