Error 111 connecting to localhost after bench update

Hi All’s
When I update frappe bench i got this problem
"redis.exceptions.ConnectionError: Error 111 connecting to localhost:11000. Connection refused.
i tried to restart Redis server also deleted dump.rdb then restart Redis server but the problem still raise.
any help please?
Best Regards


try bench update --patch

@vishdha thanks for replying.
I tried that but the "Error 111 connecting to localhost:11000. Connection refused. " problem still raises

make sure that your redis is working or not by using this command.
redis-cli ping


service redis-server start
service redis-server status

1 Like

I ran that: redis-server active “Running”

try bench update now

the same problem

Dear @pdvyas @pdvyas2
Any help please???

@Omar_Salah @vishdha
check the mysql status


Hello @sagar it’s work well

1 Like

hello @Omar_Salah,
try to stop the supervisor and nginx and restart after 5 min and check it.


I revert back to v7 :smirk::expressionless:

@sagar I tried that by the way but it didn’t work

if you are on development setup try starting bench first and then do bench update.

bench start
bench update #new terminal tab

Thanks @revant_one for reply
I really tried that before but didn’t work, I tried all tricks to solve that but all’s failed
So I revert to V7

Try running the bench in one terminal using bench start
and in another terminal use the command ‘bench migrate’ or bench update
this will keep the reddis running


thanks a lot its working

Here’s what worked for me:

sudo bench setup production <frappe-user>
sudo systemctl reload nginx

this works for me…thanks

1 Like