Error after Update to version 8.0.14

Hi there,
after updating my system to 8.0.14 version of frappe.
I am getting a strange error.
I dont know if its a bug or something.
I am trying to open a document in any doctype and it throws an error as resource not found.
Also when i click on new it throws another error.
I ll Paste the error.
When trying to open a document:

when trying to create a new Document.

Any Update On it?

Hi, Im also getting another problem as below

I am trying to Check “Is Child Table” - but no change/response.



your developer mode is not on.

Please go to sites folder and add following to the site_config.json
"developer_mode": 1,

Do not make any changes in default Masters directly. Use Customize Form for that.

I ll paste screenshot for my site confif file as well.


do bench update and try again

i tried Bench Update as Well.
Still the problem persists.
What could be wrong?


have you deleted Employee record . May be that’s why it’s not accessible.
If not try

bench clear-cache
bench clear-website-cache
bench build

For every Document it is throwing this error when using google chrome browser in console it displays error as follows:

Cannot set property ‘get_query’ of undefined
in file form.min.js

I’ll try these commands hope it solves.

It hasnt solved the problem.
In Console it shows error in file
erpnext.min.js(729:1) and form.min.js(4182:28)

Any update with the solution?

Thanks. I did not notice that before your suggestion.


Any update for the error.
I am still facing it.


Please take update one more time. Maybe it resolved.
Also try above commands.


do bench doctor and paste results here, as the will give a better clue as to what the issues are.
You can also do bench run-tests to highlight any issues, but it does take a while to run.

If all else fails and this is simply a dev/test installation might as well do a bench reinstall it will save you time & grief :slight_smile:

bench reinstall:
i guess it will wipe my database.

bench doctor gives the following output:

user@User-ThinkPad-T400:~/frappe-rk$ bench doctor
-----Checking scheduler status-----
Workers online: 3
-----None Jobs-----

Moreover the error right now i am facing is on Mozilla Firefox and not in chromium Browser.
I tried clearing cache and wiping the history too.
The problem is quite strange.

Yes it will, but as I mentioned, might be easier. If you have not done any changes to the install

Did clearing the cache & rebuild help?