Error "App Healthcare is not installed" on previously running healthcare module

Hi everyone, we’ve been running the Healthcare module at our non-profit for a couple of months now, but all of a sudden this error has popped up when we create new patient encounters, and it is unable to fetch certain patient data, and unable to fetch encounters for viewing under patient history.

I wonder whether a recent automated “Update Site Migrate” could be the culprit, or if anyone else has any ideas.

Thanks in advance to anyone who can help!

In ERPNext V14, healthcare module is removed and is made into a separate app.

If you have upgraded from V13 to V14, please see this thread on how to migrate.

1 Like

Hi, thanks for replying. No, we didn’t upgrade to V14. We previously did a trial run on V13, and chose not to upgrade so as not to complicate stuff.

I was also setting up Patient Appointments and Healthcare Service Units at about that time, as we had never used that feature before, but I don’t see how that would create this error.

Editted to add that most of the rest of the Healthcare module is actually functioning, the error seems to be quite patchy.

Can you please share versions of Frappe & ERPNext that the site is using?


Thanks for your help.

For some strange reason it has corrected itself after an “Update Site Pull”


1 Like

The error seems to have recurred again with another “Update Site Migrate”, not sure what about these updates causes the problem.


I’m also thinking whether upgrading to V14 will be helpful, and how complex it would be doing that.

I’ve just tried upgrading to V14 and installed healthcare app, initially it fixed the problem but now it has occurred again, exact same error, this time after an “Update Site Pull”. Any ideas anyone?

I’m also facing the same issue. We are getting this error “App healthcare is not installed” when we create new patient encounters or create Lab tests. I raised this issue on their github page also. Error “App Healthcare is not installed” on previously running healthcare module · Issue #131 · frappe/health · GitHub

Oh so good to finally know we’re not alone! Thanks for raising it on github as well. Yes, we have issues when creating new patient encounters, it won’t fetch the age and gender from the patient page. And we can’t view the entire list of encounters on the patient history page, it has to be done manually one at a time from the encounter list.

Yes, I agree. There are issues in patient encounter creation and laboratory function. I have to raise another issue for it on gihub. 'Gender' field not being fetched in the Lab Test form · Issue #134 · frappe/health · GitHub

Hello @tehvon, any luck in finding a solution for this issue?

Not yet unfortunately, still can’t quite figure it out.

Hello @tehvon , The health module in version 13 is still broken and there are no updates on the bug raised for it. The only way out of it is to install version 14 and install “Health module” from the marketplace - Frappe Healthcare - Frappe Cloud Marketplace
This gave me another set of problems:

  1. The ‘Healthcare’ app wasn’t showing in the side-menu few options. Example: No option to create patient/healthcare practioner etc.
  2. Lab test templates data wiped out.
  3. Patient data wiped out.

You can learn more about migration issue of “Health module” from V13 to V14 in this bug - Error while installing Healthcare App · Issue #104 · frappe/health · GitHub

I was given two possible solutions:

  1. Remove the certification field from child table in Portal Settings.
  2. Uninstall and install all the apps that you want.

If you are planning to migrate to ver 14, I would suggest to wait for sometime.