Error: 'ascii' codec can't decode byte 0xc3 in position 19: ordinal not in range(128)

“I think this is not a file name”

You have checked and can you confirm that? Your stack trace suggests otherwise

File “/usr/lib/python2.7/”, line 41, in compile_dir

I’ve checked all of custom apps, folder by folder
There’s no way to see what’s the entire name with the compile?

“there’s no way to see what’s the entire name with the compile?”

Maybe try ‘ls -R apps/your_custom_app’ to view the filenames?

No, see the file name with problem hehehe

I’ll check again, thank’s in advance for now @clarkej :smiley:

So if understood very well, the character problem is ñ right? Has some file with this char, right?

That’s what I would look for

Maybe on erpnext too? :thinking:

Good find - let us know what you learn :wink:

Do you know how can I find files name out of range of ascii encode by command line?
Like all files with ’ ñ ’ on name

I’ll uninstall erpnext on my dev machine and see if still giving error

That’s a good question - this much I know

frappe@erpnext:~/frappe-bench$ find . -name ‘*.py’ | grep ‘n’

Has to be ñ, not n.
But I cannot pass ñ on terminal too

find . -name ‘*.py’ | grep “~n”

Yes that is for us to learn.

I am out of time to research that.

Perhaps someone can chime in here…

I’m looking for do that using bytes instead character, lets see…

Thank’s for your time @clarkej :wink:

@Leonardo_Augusto Irmão, pode discobrir uma ‘ã’ em sua file name duas programas?

@clarkej ‘ñ’ is not a valid letter in Portuguese, but ‘ã’ is and is common. Neither is ‘y’. Imagine my disappointment being named ‘Tyler’.

Thanks for chiming in Tyler…you got me wondering.

Your contribution and copy paste got me this

frappe@erpnext:~/frappe-bench$ touch dummyfilenamewithñ
frappe@erpnext:~/frappe-bench$ ls -al | grep ‘ñ’
-rw-rw-r-- 1 frappe frappe 0 Dec 1 14:17 dummyfilenamewithñ
frappe@erpnext:~/frappe-bench$ find . -name ‘*’ | grep ‘ñ’

I still need to get back to you Tyler…

1 Like

The string “ñ” or “ã” not worked cause the keyboard layout of remote machine is not configured to ABNT.
So I zipped the frappe-bench folder and downloaded it on my local machine, and ran: find . -name '*.py' | grep ã
That’s worked! Found it an app folder named by sistema_de_notificação_eletrônica_de_multas then renamed to sistema_de_notificacao_eletronica_de_multas

Thank you so much for help @tmatteson and @clarkej!!