Bench Restore incomplete:'ascii' codec can't decode byte 0xd0 Error

Hello Everyone,

I have created a Master-slave replication process between 2 VMs (AW, AZ) containing 2 ERPNext instances, they are both the same in terms of Frappe, ERPNext, and custom app versions as well as data using MariaDB and Rsync.
After initializing AZ I installed all required apps and using bench restore I restored the database extracted from AW
AW instance was developed in the virtual environment using python2.7 and was already in production before AZ which is on python 3.5
After setup of AZ I have not been able to login to the slave instance I get this error

Based on the error I have discovered the offending character as Ð
Both instances have a default character encoding as en_US.UTF-8

From Similar issues found on this forum I have tried the solution here and here but none has worked for me,

I also tried running bench migrate-env for python 2.7 on AZ but I was unable to run simple bench commands like clear-cache and migrate after, forcing me to switch back to python3
screenshot of the error found in web.log

Full error log from the weblog file can be found here

I will appreciate any help I get,
Thank you.