Error while running production mode for version 12

I have deployed a fresh instance in develop mode using the easy install script , everything worked fine.
Now when i run “bench setup production”
after logging in i get this message “‘ascii’ codec can’t decode byte 0xd0 in position 1801299: ordinal not in range(128)”
any idea


it seems like your system wasn’t fully configured to use UTF-8

so how do that ? any ideas ?

To identify the source of the problem a traceback would help?

Please Note: These instructions assume you’re using Ubuntu (or any other version of Debian). If you’re not, these instructions may differ.

Open /etc/locale.gen in your favorite editor, and fine this line:

# en_US.UTF-8 UTF-8

and change it to this

en_US.UTF-8 UTF-8

Then run dpkg-reconfigure locales.

Finally, run update-locale LANG=en_US.UTF-8, and restart your system. I would recommend running these instructions on a fresh install to guarantee that there will be no issues.

If these don’t help I would ask you to post a full stack trace like @clarkej said.