Error creating new item

Just installed the virtual machine and worked through the set up wizard. Then went to create a new item and got the following error:

Traceback (innermost last):
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 67, in application
response = frappe.handler.handle()
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 74, in handle
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 99, in execute_cmd
ret =, **frappe.form_dict)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 758, in call
return fn(*args, **newargs)
TypeError: getdoctype() takes at least 1 argument (2 given)

What am I doing wrong?

On further investigation, it turns out I’m getting the same error whenever I try to create a new item using the new button at the top right of the srceen. Using the create new item text that appears within a grid seems to work fine.

This error has been fixed in a subsequent release. Can you update your VM and check.

Yes it’s all working fine now. Thank you for the quick response.