Error during ERPNext Installation

Hi Everyone,
Please help me, while installing ERPNext on Ubuntu 12.o4 LTS, I am receiving the below error everytime.

siyaram@SIYARAM:~$ wget
–2015-09-01 09:35:31--
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 12998 (13K) [text/plain]
Saving to: `’

100%[======================================>] 12,998 --.-K/s in 0s

2015-09-01 09:35:32 (119 MB/s) - `’ saved [12998/12998]

siyaram@SIYARAM:~$ sudo bash
Installing for Ubuntu precise x86
In case you encounter an error, you can post on

Adding ubuntu mariadb repo
Installing packages for Ubuntu. This might take time…
Installing wkhtmltopdf

npm ERR! Error: failed to fetch from registry: express
npm ERR! at /usr/share/npm/lib/utils/npm-registry-client/get.js:139:12
npm ERR! at cb (/usr/share/npm/lib/utils/npm-registry-client/request.js:31:9)
npm ERR! at Request._callback (/usr/share/npm/lib/utils/npm-registry-client/request.js:136:18)
npm ERR! at Request.callback (/usr/lib/nodejs/request/main.js:119:22)
npm ERR! at Request. (/usr/lib/nodejs/request/main.js:212:58)
npm ERR! at Request.emit (events.js:88:20)
npm ERR! at ClientRequest. (/usr/lib/nodejs/request/main.js:412:12)
npm ERR! at ClientRequest.emit (events.js:67:17)
npm ERR! at HTTPParser.onIncoming (http.js:1261:11)
npm ERR! at HTTPParser.onHeadersComplete (http.js:102:31)
npm ERR! You may report this log at:
npm ERR!
npm ERR! or use
npm ERR! reportbug --attach /home/siyaram/frappe-bench/npm-debug.log npm
npm ERR!
npm ERR! System Linux 3.13.0-62-generic
npm ERR! command “node” “/usr/bin/npm” “install” “” “redis” “express” “superagent” “cookie”
npm ERR! cwd /home/siyaram/frappe-bench
npm ERR! node -v v0.6.12
npm ERR! npm -v 1.1.4
npm ERR! message failed to fetch from registry: express
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/siyaram/frappe-bench/npm-debug.log
npm not ok
installing frappe
installing erpnext
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==0.92’, ‘console_scripts’, ‘bench’)()
File “/home/siyaram/bench-repo/bench/”, line 60, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 700, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 680, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1027, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 873, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 508, in invoke
return callback(*args, **kwargs)
File “/home/siyaram/bench-repo/bench/”, line 165, in init
no_auto_update=no_auto_update, frappe_path=frappe_path, frappe_branch=frappe_branch)
File “/home/siyaram/bench-repo/bench/”, line 82, in init
File “/home/siyaram/bench-repo/bench/”, line 112, in setup_socketio
exec_cmd(“npm install redis express superagent cookie”, cwd=bench)
File “/home/siyaram/bench-repo/bench/”, line 104, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: npm install redis express superagent cookie

Can you check if it works on Ubuntu 14.04?

Hi pdvyas
The moment I posted the question, I realized that I must check with 14.04.
Therefore I am upgrading the Version of Ubuntu, once it is upgraded I will try to repeat the steps again and if I found some issue, then I will let you know for the same.

Instead of upgrading, can you try on a clean install of 14.04?

Actually, I have tried to do a fresh installation of 14.04 so many times but I get an error message n number of times. I don’t remember it yet. Let me try to upgrade it and if I find an issue then I will do a fresh installation and let you know if I find any issue.

Hi Pdvyas,
It finally got installed without any issue the only issue was the version of Ubuntu.
Now with 14.04, it worked fine.