Error Easy Install CentOS 7

im trying to install ERPNext on fresh CentOS 7 1908
sudo yum update
sudo groupinstall “Development Tools”
sudo yum install python3 python3-devel python3-setuptools python3-pip
su - [erpnext user]
sudo python3 --production
Collecting pip
Using cached 0c6f96af8ce16cfbc1cb06bedf8e9164ce5551ec1/pip-19.3.1-py2.py3-none-any.whl
Installing collected packages: pip
Found existing installation: pip 19.3.1
Uninstalling pip-19.3.1:
Successfully uninstalled pip-19.3.1
WARNING: The scripts pip, pip3 and pip3.6 are installed in ‘/usr/local/bin’ wh ich is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warn ing, use --no-warn-script-location.
Successfully installed pip-19.3.1
Traceback (most recent call last):
File “”, line 413, in
File “”, line 105, in install_bench
run_playbook(‘create_user.yml’, extra_vars=extra_vars)
File “”, line 327, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib64/python3.6/”, line 306, in check_call
retcode = call(*popenargs, **kwargs)
File “/usr/lib64/python3.6/”, line 287, in call
with Popen(*popenargs, **kwargs) as p:
File “/usr/lib64/python3.6/”, line 729, in init
restore_signals, start_new_session)
File “/usr/lib64/python3.6/”, line 1364, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: ‘ansible-playbook’: ‘ans ible-playbook’
tried to do the same on CentOS 7 1805 same results

Hi everyone,

Any one managed to fix this issue… I have been trying to install erpnext for several days now but facing same above issue.
Any one have solution for it?


1 Like

i think you can install pip before initiating the install script to work around this…

sudo yum -y install python36u-pip

Hi my apologies for the late reply they easy installer had a bug with ansible version waited few days and tried after they updated it.
i agree with @akurungadam i installed pip but i used python3-pip. faced few errors while installing but either rerun or run the command manually got the process to the end. then:
remove the created site
bench update
create a new site

Hello, did you know this manual:

How To Install ERPNext on CentOS 7

Posted by admin | Jan 25, 2019 | CentOS, CMS, CRM, ERP, Tutorials




Hello, did you have a solution?