Error in installation Ubuntu 16.04 64bit

Hi, i am facing error in installation ERPNext.

I want to install Production branch please help i am new here.
I was trying to install as a easy way defined here

but i am getting this error, i also have tried many times but no luck, i also try to search in this form but i think i haven’t found my solution. can anybody help me?

TASK [Set home folder perms] ***************************************************
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: OSError: [Errno 2] No such file or directory: '/home/frappe/.mozilla/firefox/ygt4a3ls.default/'
fatal: [localhost]: FAILED! => {"changed": false, "module_stderr": "Traceback (most recent call last):\n  File \"/tmp/ansible_oUYwxP/\", line 473, in <module>\n    main()\n  File \"/tmp/ansible_oUYwxP/\", line 350, in main\n    changed |= recursive_set_attributes(module, to_bytes(file_args['path'], errors='surrogate_or_strict'), follow, file_args)\n  File \"/tmp/ansible_oUYwxP/\", line 172, in recursive_set_attributes\n    changed |= module.set_fs_attributes_if_different(tmp_file_args, changed, expand=False)\n  File \"/tmp/ansible_oUYwxP/\", line 1507, in set_fs_attributes_if_different\n  File \"/tmp/ansible_oUYwxP/\", line 1164, in set_owner_if_different\n  File \"/tmp/ansible_oUYwxP/\", line 1059, in user_and_group\nOSError: [Errno 2] No such file or directory: '/home/frappe/.mozilla/firefox/ygt4a3ls.default/'\n", "module_stdout": "", "msg": "MODULE FAILURE", "rc": 1}
	to retry, use: --limit @/tmp/.bench/playbooks/create_user.retry

PLAY RECAP *********************************************************************
localhost                  : ok=2    changed=0    unreachable=0    failed=1   

Traceback (most recent call last):
  File "", line 417, in <module>
  File "", line 100, in install_bench
    run_playbook('create_user.yml', extra_vars=extra_vars)
  File "", line 338, in run_playbook
    success = subprocess.check_call(args, cwd=os.path.join(cwd, 'playbooks'))
  File "/usr/lib/python2.7/", line 541, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['ansible-playbook', '-c', 'local', 'create_user.yml', '-e', '@/tmp/extra_vars.json']' returned non-zero exit status 2
1 Like

Note : I’ve tried installation as a root as well as frappe user

The error log which you have provided here, is it via the root user or frappe user?

i think its via frappe user,

Have the same problem, i installed via hitchhiker guide with a little tweak to get it running, still want to run easyinstall if ever

Are you trying to install inside OpenVZ or any similar container based virtualization environment? If yes, you cannot install using the install scripts at this point of time, since they’re not meant for the same. Please follow the Hitchhiker’s guide.

what is hitchhiker’s guide? please give me a link.

I just googled ‘erpnext hitchhiker’ Home · frappe/frappe Wiki · GitHub

1 Like

Actually i tried hitchhiker guide and still got errors, but i tried this guide Install Erpnext on ubuntu 16.04 LTS server · frappe/bench Wiki · GitHub
and it was completely straight forward and got the job done, hope it helps

just check also if this is a fresh server install, and does it have LAMP by default installed as it makes conflict with setup procedures

1 Like

@a.elhaidary thanks but i have already tried this but couldn’t get success,

Thanks @clarkej i’ll try this.
follow this guide , it will be good .

One caution with those instructions: Step 1 suggests to install as root is an option when in fact that is not a best practice nor advisable.

To avoid issues be sure to run install with sudo from non-root user account, for example create a frappe user and assign the account sudo privileges.

1 Like

@clarkej thanks, as per your instructions i ran all the setup,
i added required lines in my.cnf but i am unable to restart mariadb service.
& i am also unable to create site because of this.
please take a look.

frappe@localhost:~$ cd frappe-bench/
frappe@localhost:~/frappe-bench$ bench new-site site1.local
MySQL root password: 
Creation of your site - site1.local failed because MariaDB is not properly 
configured to use the Barracuda storage engine. 
Please add the settings below to MariaDB's my.cnf, restart MariaDB then 
run `bench new-site site1.local` again.

character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci

default-character-set = utf8mb4

frappe@localhost:~/frappe-bench$ cd ..
frappe@localhost:~$ sudo service mysql restart
[sudo] password for frappe: 
Job for mariadb.service failed because a timeout was exceeded. See "systemctl status mariadb.service" and "journalctl -xe" for details.
frappe@localhost:~$ sudo systemctl status mariadb.service
● mariadb.service - MariaDB 10.2.15 database server
   Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: 
  Drop-In: /etc/systemd/system/mariadb.service.d
   Active: failed (Result: timeout) since Tue 2018-05-22 03:30:59 UTC; 53s ago
     Docs: man:mysqld(8)
  Process: 4020 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WS
  Process: 3615 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR
  Process: 3608 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START
  Process: 3604 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/ru
 Main PID: 4020 (code=exited, status=0/SUCCESS)

May 22 03:29:26 localhost.localdomain systemd[1]: Starting MariaDB 10.2.15 datab
May 22 03:29:27 localhost.localdomain mysqld[4020]: 2018-05-22  3:29:27 14062503
May 22 03:30:57 localhost.localdomain systemd[1]: mariadb.service: Start operati
May 22 03:30:59 localhost.localdomain systemd[1]: Failed to start MariaDB 10.2.1
May 22 03:30:59 localhost.localdomain systemd[1]: mariadb.service: Unit entered 
May 22 03:30:59 localhost.localdomain systemd[1]: mariadb.service: Failed with r
lines 1-19/19 (END)

“Job for mariadb.service failed because a timeout was exceeded.”

This refers to a failed connection, a timeout typically is due to a closed port.

This should give you details to confirm that?

mariadb expects port 3306 to be open - to check for that run this:

frappe@ubuntu:~/frappe-bench$ sudo ufw status | grep 3306
3306/tcp                   ALLOW       Anywhere                  
3306/tcp (v6)              ALLOW       Anywhere (v6)  

To open it do this:

sudo ufw allow 3306/tcp


frappe@localhost:~$ cd frappe-bench
frappe@localhost:~/frappe-bench$ sudo ufw status | grep 3306
[sudo] password for frappe: 
Sorry, try again.
[sudo] password for frappe: 
sudo: ufw: command not found
frappe@localhost:~/frappe-bench$ sudo ufw allow 3306/tcp
sudo: ufw: command not found

@clarkej hi,
i’ve success fully installed ERPNext,
i switched it to Master,
then i ran bench update – patch
i got this
Branch master does not exist in Upstream for erpnext
Successfully switched branches for:
Switched to master
Please run bench update --patch to be safe from any differences in database schema
frappe@localhost:~/frappe-bench$ bench update --patch
Backing up sites…
Patching sites…
Migrating site2.local
Executing execute:frappe.reload_doc(‘core’, ‘doctype’, ‘docfield’, force=True) #2017-03-03 in site2.local (a46003081c220c38)
Updating DocTypes for frappe : [ ]Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/”, line 72, in _run_code
exec code in run_globals
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 94, in
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 18, in main
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 24, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 222, in migrate
migrate(context.verbose, rebuild_website=rebuild_website)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 33, in migrate
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 19, in sync_all
sync_for(app, force, verbose=verbose, reset_permissions=reset_permissions)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 45, in sync_for
reset_permissions=reset_permissions, for_sync=True)
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 58, in import_file_by_path
ignore_version=ignore_version, reset_permissions=reset_permissions)
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 132, in import_doc
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 240, in insert
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 303, in db_insert
), list(d.values()))
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 166, in sql
self._cursor.execute(query, values)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 170, in execute
result = self._query(query)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 328, in _query
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 893, in query
self._affected_rows = self._read_query_result(unbuffered=unbuffered)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 1103, in _read_query_result
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 1396, in read
first_packet = self.connection._read_packet()
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 1059, in _read_packet
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 384, in check_error
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 109, in raise_mysql_exception
raise errorclass(errno, errval)
pymysql.err.IntegrityError: (1048, u"Column ‘translatable’ cannot be null")

and getting this on my browser

Your system is being updated. Please refresh again after a few moments

Status: 503

ok a search turned up this that might offer clues and options to try!?

Column 'translatable' cannot be null

fixed column ‘translatable’ cannot be null,
now getting this :confused:
Column ‘allow_in_quick_entry’ cannot be null

why installing ERPNext is so hard?
i am stuck in just installing it over a week ago but yet no luck. :frowning: