Error in last step of installation bench install-app erpnext

Executing the last step of the installation I received this error:

Traceback (most recent call last):
File “/opt/lsa/python/lib/python2.7/”, line 162, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/opt/lsa/python/lib/python2.7/”, line 72, in _run_code
exec code in run_globals
File “/home/lsa/frappe-bench/apps/frappe/frappe/utils/”, line 77, in
File “/home/lsa/frappe-bench/apps/frappe/frappe/utils/”, line 14, in main
File “/home/lsa/frappe-bench/env/lib/python2.7/site-packages/click/”, line 664, in call
return self.main(*args, **kwargs)
File “/home/lsa/frappe-bench/env/lib/python2.7/site-packages/click/”, line 644, in main
rv = self.invoke(ctx)
File “/home/lsa/frappe-bench/env/lib/python2.7/site-packages/click/”, line 991, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/lsa/frappe-bench/env/lib/python2.7/site-packages/click/”, line 991, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/lsa/frappe-bench/env/lib/python2.7/site-packages/click/”, line 837, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/lsa/frappe-bench/env/lib/python2.7/site-packages/click/”, line 464, in invoke
return callback(*args, **kwargs)
File “/home/lsa/frappe-bench/apps/frappe/frappe/”, line 28, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/lsa/frappe-bench/apps/frappe/frappe/”, line 159, in install_app
for site in context.sites:
TypeError: ‘NoneType’ object is not iterable

Do you know what is the problem? It seems that they don’t populate the database.

Seems like you have not created site properly or did not mention / wrongly mention while installing app.

I just followed the Setting Up ERPNext steps that you provide in GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps. Do I have to do something more?

okay, just spent a couple hours on this because didn’t know what went wrong. Basically i missed this warning when adding the site, which doesn’t look like a warning =)). So the site’s db is there but empty :smiley:

Please add this to MariaDB's my.cnf and restart MariaDB before proceeding

character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci

default-character-set = utf8mb4

Hopefully it helps

1 Like