Error initialising ERPNext Installation

I need help getting a new installation to startup.

I successfully installed an instance of ERPNext on a local machine but while starting it up it fails:

I checked nginx log and this is what i found.

2018/05/19 14:55:32 [error] 1276#1276: *67 upstream timed out (110: Connection timed out) while reading response header from upstream, client:, server: site1.local, request: “POST / HTTP/1.1”, upstream: “”, host: “”, referrer: “

i don’t quite understand what this error is so i need help. I’ve set up several instances in the cloud and this is my first installation on a local machine.

  1. Does clicking “Retry” not complete the setup wizard ?
  2. If you are still able to replicate the error. Can you post your topmost commit hash for frappe and erpnext using git login their respective directories


No clicking Retry does not fix the problem. I even formatted the entire server and reinstalled Ubuntu 16.04.4 LTS but i still got the same error after installing ERPNext using the easy install script.

I really do wish i can understand how to extract this info. I have zero coding knowledge so i don’t play around with commands. I would appreciate if you could point me to info on how to get this out. I will gladly get the info out as you have requested.

Hello @flexy2ky

You can tried bench clear-cache command in restart the server.


Nope that didn’t work either.

@flexy2ky is this happening on a fresh install ??

To check the last commit goto the frappe folder using this command:
cd ~/frappe-bench/apps/frappe
then type git rev-parse HEAD and paste the output here.
Same for erpnext, goto the erpnext folder using
cd ~/frappe-bench/apps/erpnext
and then use git rev-parse HEAD and paste the output here.

Here you go:

frappe@frappe-desktop:~/frappe-bench/apps/frappe$ git rev-parse HEAD

frappe@frappe-desktop:~/frappe-bench/apps/erpnext$ git rev-parse HEAD

@flexy2ky can you tell me your server configuration. No of CPU cores, RAM, Operating System.

I tried replicating the issue. The error message does pop up, but on clicking “Retry” once or twice it always finishes up the setup wizard. The issue is occurring because there are a lot of tasks which are queued in the back end.

The server configuration is intel Celeron 2.4GHz Dual Core, 4GB RAM. I tried Ubuntu 16.04 Desktop and Server as well as CentoOS 7 and Debian 8 and got the same error for v10 production. I tried Ubuntu 18.04 server and was successful in installing v11 develop beta once on the same machine but the installation process was tedious with MariaDB giving all sorts of user permission issues when creating a site. I don’t know how i fixed that the first time but i tried to replicate the error to determine how i fixed the permission issues the first time but all the steps i followed wouldn’t work.