Error install apps

hello Team

i am having issues installing apps on my instance. any tip on how to fix?

Command “python egg_info” failed with error code 1 in /tmp/pip-build-AnL4w1/frappe/

bench get-app bench_manager GitHub - frappe/bench_manager: Frappe app for managing bench app bench_manager
INFO:bench.utils:git clone GitHub - frappe/bench_manager: Frappe app for managing bench --depth 1 --origin upstream
Cloning into ‘bench_manager’…
remote: Counting objects: 65, done.
remote: Compressing objects: 100% (52/52), done.
remote: Total 65 (delta 13), reused 29 (delta 4), pack-reused 0
Unpacking objects: 100% (65/65), done.
Checking connectivity… done.
(‘installing’, u’bench_manager’) bench_manager
INFO:bench.utils:./env/bin/pip install -q -e ./apps/bench_manager --no-cache-dir
Command “python egg_info” failed with error code 1 in /tmp/pip-build-0xtwtB/frappe/
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/ubuntu/frappe-bench/src/frappe-bench/bench/”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/ubuntu/frappe-bench/src/frappe-bench/bench/commands/”, line 40, in get_app
get_app(git_url, branch=branch)
File “/home/ubuntu/frappe-bench/src/frappe-bench/bench/”, line 133, in get_app
install_app(app=app_name, bench_path=bench_path, verbose=verbose)
File “/home/ubuntu/frappe-bench/src/frappe-bench/bench/”, line 164, in install_app
File “/home/ubuntu/frappe-bench/src/frappe-bench/bench/”, line 153, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: ./env/bin/pip install -q -e ./apps/bench_manager --no-cache-dir

Hi @EnSeal

Have you tried updating setup tools?

pip install --upgrade setuptools

You can use that command and try again

Kind regards,

Hi @System19

Thanks a lot for pointing out the typo! I’ve amended accordingly


Hi @EnSeal

Can you please confirm if this is fixed and how you fixed it?


@EnSeal check your pip version. It must be 10.0.0.
Try downgrading to 9.0.3 using:
pip install pip==9.0.3

Also do a git pull in your bench-repo folder


I had to reinstall and restore backup on a clean setup