Error installing [create user] failed on clean AWS Ubuntu Server 16.04 LTS


I tried the install script on a clean AWS VPS. I got the error below.
Does anyone has a solution?
thanks, Bart

[WARNING]: Host file not found: /etc/ansible/hosts

[WARNING]: provided hosts list is empty, only localhost is available

PLAY [localhost] ***************************************************************

TASK [setup] *******************************************************************
ok: [localhost]

TASK [Create user] *************************************************************
fatal: [localhost]: FAILED! => {“changed”: false, “failed”: true, “msg”: “useradd: Permission denied.\nuseradd: cannot lock /etc/passwd; try again later.\n”, “name”: “frappe”, “rc”: 1}

NO MORE HOSTS LEFT *************************************************************
to retry, use: --limit @develop/create_user.retry

PLAY RECAP *********************************************************************
localhost : ok=1 changed=0 unreachable=0 failed=1

It seems to be a permissions issue - maybe you need to use sudo?

What are you running on the command line?

Have you manually tried to add user ‘frappe’ account?


A few people have followed these steps and have successfully installed on Ubuntu 16.10 and should work fine on 16.04

1. sudo apt-get update
2. sudo apt-get upgrade
3. sudo adduser frappe
4. sudo usermod -aG sudo frappe
5. sudo nano /etc/resolv.conf
6. sudo apt-get install python-minimal && python -V # was 2.7.12+
7. wget
8. sudo python --production

Hope it helps.

Thanks for Both answers.Sudo solved the trick for the first error message, but later on I struggled with the mySql setup, some password error. I always thought the default mySql root password is blank.I will try these steps later Today and let you know.

Van: discuss@erpnext.comVerzonden: 11 april 2017 04:05Aan: kramer.bart@gmail.comBeantwoorden: discuss+reply+a5b94330cfaf052b652935339d614c41@frappe.ioOnderwerp: [erpnext-discuss] [Install / Update/Setup] Error installing [create user] failed on clean AWS Ubuntu Server 16S