Error NoneType when install custom app

I have a custom app that worked before.
Yesterday I made some change and committed it to my repo.
And it still worked fine.

Today I made new site and install the customapp and got error message when doing this bench command:

$ bench --site install-app customapp

the error is when updating Doctype half way (see the [===] isn’t finished)

Installing customapp...
Updating DocTypes for customapp : [===============                         ]
An error occurred while installing customapp:
expected str, bytes or os.PathLike object, not NoneType

What is this error?
How can I know what’s wrong?
Where is the process log? I see the bench.log doesn’t have the information.
Thank you

I agree there should be a traceback where the error occured. For now, try adding the traceback print manually.

Add the following line on line 221 in


Try installing your customapp again, the traceback should get printed.

If this worked for you, you can send a PR with that print statement, it might be useful to others too.

1 Like

Yes. thank you for that.
Silly me… I was making my customapp logging and unaware that I set the log file path from a field within the custom app itself :smiley:

I will send PR for this useful line.