Error on Setup Production with the last update

Im on OS X, and i had worked fine at last update now if i try a setup production i have this error:

$ sudo bench setup production frappe
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==0.0.0’, ‘console_scripts’, ‘bench’)()
File “/Developers/bench-repo/bench/”, line 40, in cli
File “/Library/Python/2.7/site-packages/click/”, line 716, in call
return self.main(*args, **kwargs)
File “/Library/Python/2.7/site-packages/click/”, line 696, in main
rv = self.invoke(ctx)
File “/Library/Python/2.7/site-packages/click/”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Library/Python/2.7/site-packages/click/”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Library/Python/2.7/site-packages/click/”, line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/Library/Python/2.7/site-packages/click/”, line 534, in invoke
return callback(*args, **kwargs)
File “/Developers/bench-repo/bench/commands/”, line 43, in setup_production
File “/Developers/bench-repo/bench/config/”, line 20, in setup_production
os.symlink(os.path.abspath(os.path.join(bench, ‘config’, ‘supervisor.conf’)), supervisor_conf)
OSError: [Errno 17] File exists

i know it says the supervisor.conf exists, but i don’t know where it looking for i delete it from:


but when i run

$ sudo bench setup production frappe

supervisor.conf papers there

anyone knows which is the problem ?

Thank you!

Try these steps and then try setting up production:

rm config/supervisor.conf
rm config/nginx.conf
sudo service nginx stop
sudo service supervisor stop

I had the same problem in Ubuntu 14.04.3. I solved it deleting the symbolic link /etc/supervisor/conf.d/frappe-bench.conf (that in my case links to $HOME/frappe-bench/config/supervisor.conf). The same problem happens with /etc/nginx/conf.d/frappe-bench.conf.


i’ll try it!.. thank you!