Error on sudo bash

Dear all,
I was trying to install frappe + erpnext with Bench on a VPS on DigitalOcean (Ubuntu), I ran on this error (I tried from a snapshot I used before without any issue).

sudo bash
Selecting previously unselected package redis-tools.
Preparing to unpack …/redis-tools_2%3a2.8.4-2_amd64.deb …
Unpacking redis-tools (2:2.8.4-2) …
Selecting previously unselected package redis-server.
Preparing to unpack …/redis-server_2%3a2.8.4-2_amd64.deb …
You are required to change your password immediately (root enforced)
chfn: PAM: Authentication token is no longer valid; new one required
adduser: `/usr/bin/chfn -f redis server redis’ returned error code 1. Exiting.
dpkg: error processing archive /var/cache/apt/archives/redis-server_2%3a2.8.4-2_amd64.deb (–unpack):
subprocess new pre-installation script returned error exit status 1
Selecting previously unselected package python-meld3.
Preparing to unpack …/python-meld3_0.6.10-1_amd64.deb …
Unpacking python-meld3 (0.6.10-1) …
Selecting previously unselected package supervisor.
Preparing to unpack …/supervisor_3.0b2-1_all.deb …
Unpacking supervisor (3.0b2-1) …
Processing triggers for ureadahead (0.100.0-16) …
Processing triggers for man-db ( …
Processing triggers for mime-support (3.54ubuntu1) …
Processing triggers for ufw (0.34~rc-0ubuntu2) …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any ideas?

@pdvyas will be back later today. Maybe he can shed some light :smile:

I tested on both Ubuntu 12.04 and 14.04 on Digital Ocean and it did setup successfully. Can you rebuild your droplet and try again?

Sorry I missed your response.
I did retry and the problem happens when I try the easy install on an snapshot / image on digital ocean. The image has just ssh + swap (a clean base to install bench / frappe).
If I start from scratch no problem, but I create a new droplet, then install the image, then try the easy install, it gives me the same error.