ERROR: Package 'frappe' requires a different Python: 3.8.13 not in '>=3.10'

I’m getting this error when I gave bench init test && cd test


may we know the operating/hosting environment, version of frappe/ERPNext and how they were installed? What does python3 -V return?

Latest frappe develop version now requires python 3.10+

ref: Dropping python <=3.9 support for next version of Frappe/ERPNext - #7 by ankush

Continue discussion in that same thread if reqd