Error show during bench start

When i run “bench start” command… below error show

8255:M 18 Mar 16:31:09.349 # Server initialized
16:31:09 redis_cache.1    | 8255:M 18 Mar 16:31:09.349 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
16:31:09 redis_cache.1    | 8255:M 18 Mar 16:31:09.349 * Ready to accept connections
16:31:09 system           | socketio.1 started (pid=8245)
16:31:10 socketio.1       | listening on *: 3000
16:31:10 socketio.1       | events.js:183
16:31:10 socketio.1       |       throw er; // Unhandled 'error' event
16:31:10 socketio.1       |       ^
16:31:10 socketio.1       | 
16:31:10 socketio.1       | Error: Redis connection to failed - connect ECONNREFUSED
16:31:10 socketio.1       |     at Object._errnoException (util.js:1022:11)
16:31:10 socketio.1       |     at _exceptionWithHostPort (util.js:1044:20)
16:31:10 socketio.1       |     at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1198:14)
16:31:10 system           | socketio.1 stopped (rc=1)
16:31:10 system           | sending SIGTERM to redis_socketio.1 (pid 8223)

Aby solution for this problem?

Seems like your node environment isn’t completely set up for your bench. Running bench setup requirements --node && bench build in your bench directory should fix this.

Did it… But same error show during bench run

what is available memory of your server/workstation?

This appears to be the key error message. Bench/ERPNext cannot make a connection to Redis.

The default ports for Redis (with ERPNext) are 11000, 12000, and 13000. The message indicates you’ve configured 12311.

  1. Examine your Procfile (located in the root of your bench directory). Verify it’s configured to auto-launch Redis.
  2. Examine the Redis configuration files that Procfile refers to. Check those port numbers.
  3. Examine your “common_site_config.json” file. Verify the Redis ports in there match those from the Redis configuration files.

Thanks brian_pond… it’s may be my redis configuration problem… so i remove redis completely and install it again … now its working

1 Like