ERROR: sudo supervisorctl restart frappe-bench-web

I tried setting up an ERPNext Production mode in a VM. I’m encountering the following error when I try “bench restart” command:

I checked my redis and nginx status. Both of them are running and active.

Thanks in advance!

frappe@ubuntu:~/frappe-bench$ sudo systemctl status nginx
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2024-06-13 12:35:07 UTC; 18h ago
Docs: man:nginx(8)
Process: 67343 ExecReload=/usr/sbin/nginx -g daemon on; master_process on; -s reload (code=exited, status=0/SUCCESS)
Main PID: 11187 (nginx)
Tasks: 6 (limit: 9388)
Memory: 4.9M
CPU: 513ms
CGroup: /system.slice/nginx.service
├─11187 “nginx: master process /usr/sbin/nginx -g daemon on; master_process on;”
├─67344 “nginx: worker process” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “”
├─67345 “nginx: worker process” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “”
├─67346 “nginx: worker process” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “”
├─67347 “nginx: worker process” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “”
└─67348 “nginx: cache manager process” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “”

Jun 13 12:35:07 ubuntu systemd[1]: Starting A high performance web server and a reverse proxy server…
Jun 13 12:35:07 ubuntu systemd[1]: Started A high performance web server and a reverse proxy server.
Jun 13 12:35:20 ubuntu systemd[1]: Reloading A high performance web server and a reverse proxy server…
Jun 13 12:35:20 ubuntu systemd[1]: Reloaded A high performance web server and a reverse proxy server.
Jun 13 12:39:02 ubuntu systemd[1]: Reloading A high performance web server and a reverse proxy server…
Jun 13 12:39:02 ubuntu systemd[1]: Reloaded A high performance web server and a reverse proxy server.
Jun 14 04:22:34 ubuntu systemd[1]: Reloading A high performance web server and a reverse proxy server…
Jun 14 04:22:34 ubuntu systemd[1]: Reloaded A high performance web server and a reverse proxy server.
frappe@ubuntu:~/frappe-bench$ sudo systemctl redis status
Unknown command verb redis.
frappe@ubuntu:~/frappe-bench$ sudo systemctl status redis
● redis-server.service - Advanced key-value store
Loaded: loaded (/lib/systemd/system/redis-server.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2024-06-13 11:25:04 UTC; 19h ago
Docs: Docs,
man:redis-server(1)
Main PID: 3478 (redis-server)
Status: “Ready to accept connections”
Tasks: 5 (limit: 9388)
Memory: 2.6M
CPU: 34.790s
CGroup: /system.slice/redis-server.service
└─3478 “/usr/bin/redis-server 127.0.0.1:6379” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “”>

Jun 13 11:25:04 ubuntu systemd[1]: Starting Advanced key-value store…
Jun 13 11:25:04 ubuntu systemd[1]: Started Advanced key-value store.
lines 1-15/15 (END)

This worked for me ( got help from the telegram) :grinning:

bench setup socketio
bench setup supervisor
bench setup redis
sudo supervisorctl reload
sudo bench setup procfile
bench restart

2 Likes