Error when importing : Cannot match column


I’m importing DocType definitions, ie the doctype is DocType. I’ve been doing this for years, but now in version 13.24 I get an error.

I download the csv template and then add the appropriate values. So I upload the exact same csv template with the same column headings as I’ve download. Even if I manually map the 4 columns I get the same error : Cannot match column.

Any idea what’s causing this?

I’ve tested the same csv file on a v13.10 instance and it works fine

Here’s the csv

ID,Module,Custom?,Label (Fields),Type (Fields),Name (Fields)
1 Like

I have the same problem.

Thanks @szufisher.

However I’ve reached the end of my technical capabilities in my attempts to figure out what’s going wrong.

I get the same error when trying to import the exact same file via “bench data-import”

TypeError: unhashable type: ‘_dict’

Don’t know what to do now?

It worked for me when I replaced the doctype between brackets with (None), this happened when I tried to import sales invoice, and it could not recognise all fields related to item child table (e.g. Item (items)) so I replaced it with (Item (None) and it worked,


Can you please elaborate more about this because every time I try to import the sales invoice, i have to first map columns
Thank you

Worked for me too… thanks !

Kind regards,

What does this mean “replaced it with (Item (None)”?

I have this same problem…it is quite frustrating. The first time I got

" COLUMN 1 ( ID)

Cannot match column ID with any field"

That was when I was trying to use ID but then I noticed, in the download template, that ID is actually the user e-mail address (I am trying to update user accounts) so I changed the ID column to email address but I get the same error.


Replying to myself here. I managed to get this to work but doing the following:

  1. Put the email address of the user(s) in a column titled ID

  2. When the initial loading of the file results in an error

" COLUMN 1 ( ID)

Cannot match column ID with any field"

click on “Map columns” can map the ID column to the ID Name column title that appears in the list. It seems like this should work without the need to “Map” but at any rate mapping it worked for me. :wink:

1 Like